2010-09-16 08:09:45     BF561 EZ-kit Lite u-boot crashed after "saveenv"

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2010-09-16 08:09:45     BF561 EZ-kit Lite u-boot crashed after "saveenv"

Fisher Ho (TAIWAN)

Message: 93505   

 

Hello,

 

 

 

       I downloaded  the binary version of u-boot and burn it on the flash.

 

 

 

      It worked well....but after I type "saveenv"...in the command line   (No variables changed)...

 

 

 

      It crashed and couldn't get back any more.

 

 

 

--------------------------

 

 

 

U-Boot 2010.06 (ADI-2010R1-ALPHA-3) (Aug 02 2010 - 19:12:59)           ------->2009R1 version is the same

 

CPU:   ADSP bf561-0.3 (Detected Rev: 0.5) (parallel flash boot)

Board: ADI BF561 EZ-Kit Lite board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 600 MHz, Core: 600 MHz, System: 100 MHz

RAM:   64 MiB

Flash: 8 MiB

*** Warning - bad CRC, using default environment

 

In:    serial

Out:   serial

Err:   serial

KGDB:  [on serial] ready

Net:   SMC91111-0

Hit any key to stop autoboot:  0

bfin>                                                      --->it worked

bfin>

bfin> printenv

bootargs=root=/dev/mtdblock0 rw clkin_hz=30000000 earlyprintk=serial,uart0,57600

console=ttyBF0,57600

bootcmd=run ramboot

bootdelay=5

baudrate=57600

loads_echo=1

ipaddr=192.168.0.15

serverip=192.168.0.2

autoload=no

rootpath=/romfs

gatewayip=192.168.0.1

netmask=255.255.255.0

hostname=bf561-ezkit

loadaddr=0x1000000

ubootfile=u-boot.ldr

update=tftp $(loadaddr) $(ubootfile);protect off 0x20000000 +$(filesize);erase 0

x20000000 +$(filesize);cp.b $(loadaddr) 0x20000000 $(filesize)

addip=set bootargs $(bootargs) ip=$(ipaddr):$(serverip):$(gatewayip):$(netmask):

$(hostname):eth0:off

ramfile=uImage

ramargs=set bootargs root=/dev/mtdblock0 rw clkin_hz=30000000 earlyprintk=serial

,uart0,57600 console=ttyBF0,57600

ramboot=tftp $(loadaddr) $(ramfile);run ramargs;run addip;bootm

nfsfile=vmImage

nfsargs=set bootargs root=/dev/nfs rw nfsroot=$(serverip):$(rootpath),tcp,nfsver

s=3

nfsboot=tftp $(loadaddr) $(nfsfile);run nfsargs;run addip;bootm

flashboot=bootm 0x20100000

stdin=serial

stdout=serial

stderr=serial

ethact=SMC91111-0

 

Environment size: 1023/8188 bytes

bfin> saveenv

Saving Environment to Flash...

Un-Protected 8 sectors

Erasing Flash...

........ done

Erased 8 sectors

Writing to Flash... done

Protected 8 sectors

bfin>

 

U-Boot 2010.06 (ADI-2010R1-ALPHA-3) (Aug 02 2010 - 19:12:59)

 

CPU:   ADSP bf561-0.3 (Detected Rev: 0.5) (parallel flash boot)

Board: ADI BF561 EZ-Kit Lite board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 600 MHz, Core: 600 MHz, System: 100 MHz

RAM:   64 MiB

Flash:

 

----------------------------------------------------------------------------------------

 

than it couldn't get back anymore.  Would someone has good idea?...QQ

 

 

 

ps. I used VisualDSP to burn the flash.

 

TranslateQuoteReplyEditDelete

 

 

2010-09-16 12:55:26     Re: BF561 EZ-kit Lite u-boot crashed after "saveenv"

Mike Frysinger (UNITED STATES)

Message: 93510   

 

use bypass boot mode, not parallel flash

QuoteReplyEditDelete

 

 

2010-09-17 02:16:53     Re: BF561 EZ-kit Lite u-boot crashed after "saveenv"

Fisher Ho (TAIWAN)

Message: 93525   

 

Thank you,

 

 

 

I burned the .bin version of u-boot and adjust the bootmode SW3 buttom to 0010, it works!!

 

 

 

But it's strange that my manual described that 0010    00---->reserved...

 

it works,   thanks

Attachments

    Outcomes