2010-05-20 14:32:20     Problem in network smc91111i

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2010-05-20 14:32:20     Problem in network smc91111i

anoob CS (INDIA)

Message: 89600   

 

I am using bf561 coustome board having smc91111i for networking.

 

I loaded uboot to flash, and it is working fine. But i am not able to ping to my server (ip is correct). i also tried ip 127.0.0.1.not working.

 

 

 

"autonegotiation timed out" this is comming. if i connect cable the led is not glowing (i tried another cable also).

 

 

 

I loaded vmimage.gz by loadb it is working fine, but network is not up. here 127.0.0.1 is working. but i am not able to ping with server.(network connection is not showing).

 

 

 

what i have to do to make network up in uboot.

 

 

 

Thanks

 

Anoob C S

QuoteReplyEditDelete

 

 

2010-05-20 15:08:54     Re: Problem in network smc91111i

Robin Getz (UNITED STATES)

Message: 89602   

 

What does U-Boot print when it boots?

 

-Robin

QuoteReplyEditDelete

 

 

2010-05-22 14:32:19     Re: Problem in network smc91111i

anoob CS (INDIA)

Message: 89689   

 

U-Boot 2009.08 (ADI-2009R2-pre) (May 21 2010 - 13:14:38)

 

CPU:   ADSP bf561-0.5 (Detected Rev: 0.5) (parallel flash boot)

Board: NPLTSBF201561 board

Support: NPOL Thrikkakara, Kochin-21

Clock: VCO: 500 MHz, Core: 500 MHz, System: 100 MHz

RAM:   128 MB

Flash: 64 MB

*** Warning - bad CRC, using default environment

 

In:    serial

Out:   serial

Err:   serial

Net:   SMC91111-0

Hit any key to stop autoboot:  5     4     0

bfin> printenv

bootargs=root=/dev/mtdblock0 rw clkin_hz=50000000 earlyprintk=serial,uart0,115200 console=ttyBF0,115200

bootcmd=run ramboot

bootdelay=5

baudrate=115200

loads_echo=1

ethaddr=02:80:ad:20:31:e8

ipaddr=192.168.0.15

serverip=192.168.0.2

autoload=no

rootpath=/romfs

gatewayip=192.168.0.1

netmask=255.255.255.0

hostname=bf561-npltsbf201561

loadaddr=0x1000000

ubootfile=u-boot.ldr

update=tftp $(loadaddr) $(ubootfile);protect off 0x20000000 +$(filesize);erase 0x20000000 +$(filesize);cp.b $(loadaddr) 0x20000000 $(filesize)

addip=set bootargs $(bootargs) ip=$(ipaddr):$(serverip):$(gatewayip):$(netmask):$(hostname):eth0:off

ramfile=uImage

ramargs=set bootargs root=/dev/mtdblock0 rw clkin_hz=50000000 earlyprintk=serial,uart0,115200 console=ttyBF0,115200

ramboot=tftp $(loadaddr) $(ramfile);run ramargs;run addip;bootm

nfsfile=vmImage

nfsargs=set bootargs root=/dev/nfs rw nfsroot=$(serverip):$(rootpath),tcp,nfsvers=3

nfsboot=tftp $(loadaddr) $(nfsfile);run nfsargs;run addip;bootm

flashboot=bootm 0x20100000

stdin=serial

stdout=serial

stderr=serial

ethact=SMC91111-0

 

Environment size: 1062/16380 bytes

bfin>

 

 

 

this is the output of uboot while booting

 

 

 

thanks

QuoteReplyEditDelete

 

 

2010-05-22 22:03:54     Re: Problem in network smc91111i

Mike Frysinger (UNITED STATES)

Message: 89690   

 

127.0.0.1 makes no sense in the u-boot context.  that only works on your desktop system because your distro specifically created a loopback device with that IP for you.

 

check your cable with known working machines so you know the cable is correct.  if the link light still doesnt appear, you should double check the phy<->mac connections.  otherwise, the smsc driver has extended debugging you can (and should) enable to see what's going on.

QuoteReplyEditDelete

 

 

2010-05-24 15:29:16     Re: Problem in network smc91111i

anoob CS (INDIA)

Message: 89805   

 

I gave debugging option 2, that is greater than option 1,2,3.

 

After loading the u boot i got the output as follow(attached with this thread).

 

What would be my problem ?

 

in smc91111i to cablesection or other ?

 

 

 

Thanks

 

out.txt

QuoteReplyEditDelete

 

 

2010-05-24 15:37:50     Re: Problem in network smc91111i

Mike Frysinger (UNITED STATES)

Message: 89807   

 

you could also try tweaking your async bank timings.  and enabling CONFIG_SMC_USE_IOFUNCS in your board config.  and defining or undefining CONFIG_SMC_USE_32_BIT.

 

all in all, you need to find out why this is happening:

SMC91111: PHY auto-negotiate timed out

 

that might involve reading the debug output you just posted and comparing it to the datasheet.  we arent SMSC nor do we develop the driver, so it might be better if you contact SMSC for support instead of us.

QuoteReplyEditDelete

 

 

2010-06-02 23:33:01     Re: Problem in network smc91111i

anoob CS (INDIA)

Message: 90087   

 

I solved the problem.

 

The problem is after smc IC. That is, there is a transformer between IC and cable. This transformer was not working. that is no connection between IC and cable.

 

As per ur sugession i checked my cable, there is no problem. Then only posiblity was on this Transformer.

 

Thanks Mr.Mike Frysinger for helping me

 

 

 

I am closing the thread.........

Attachments

Outcomes