2010-04-27 10:15:43     uBoot loading problem with LdrViewer

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2010-04-27 10:15:43     uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 88963   

 

Hi All

 

I have a new designed board with the BF537. When uploaded the u-boot_UARTBOOT.ldr for this model the first time it worked very well following the guidelines of this document: http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:loading Using Hyperterminal I was able to get the promt and berform a view commands.  I've done a mtest before I wanted to copy the u-boot to flash. mtest would take for ever and decided to restart the platform and start over.

 

Now when uploading u-boot using LdrViewer, I don't get a response back after upload was done, as per point 11 of the link above. Hyperterminal is blank.

 

I use 9600 baud as indicated as it was the speed I used the first time, and Hyperterminal worked at 115200 baud.

 

Anyone an idee why I don't get a response back after uBoot UART upload?

 

See screen snapshots below.

 

Cyberfreak

 

uBoot-LdrViewer-no-response.JPG

uBoot-LdrViewer.JPG

QuoteReplyEditDelete

 

 

2010-04-27 12:20:14     Re: uBoot loading problem with LdrViewer

Mike Frysinger (UNITED STATES)

Message: 88966   

 

there is a troubleshooting section in that document

QuoteReplyEditDelete

 

 

2010-04-27 13:09:50     Re: uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 88970   

 

Hi Mike

 

It is none of those troubleshooting points.

 

Vivian

QuoteReplyEditDelete

 

 

2010-04-27 15:35:03     Re: uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 88971   

 

Hi All

 

Does anyone know why I don't get a response back from Blackfin anymore? I've tried everything and tested everything.

 

Vivian

QuoteReplyEditDelete

 

 

2010-04-28 13:14:27     Re: uBoot loading problem with LdrViewer

Robin Getz (UNITED STATES)

Message: 88997   

 

Vivian:

 

So, which work, and which don't? or they all work?

 

-Robin

QuoteReplyEditDelete

 

 

2010-04-28 14:52:07     Re: uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 88998   

 

Hi Robin

 

I'm not sure what you mean? I received a response from BlackFin after loading the ldr file as indicated by the first snapshot image. Now doing exactly what I was doing last time, BlackFin doesn't reply with a response as per document; hence HyperTerminal blank. Even tried many different baud rates.

 

Vivian

QuoteReplyEditDelete

 

 

2010-04-29 03:12:03     Re: uBoot loading problem with LdrViewer

Mike Frysinger (UNITED STATES)

Message: 89010   

 

Robin is talking about the troubleshooting steps

QuoteReplyEditDelete

 

 

2010-04-29 03:32:41     Re: uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 89026   

 

Hi Robin

 

Non of the troubleshooting points are applicable. There is coms to the BlackFin, it does upload the ldr file with the response ...done. But I don't get the "Feedback from the target board" anymore as indicated at point 11 of the document; hence I don't get any response in HyperTerminal either as before, even in any board rate.

 

What can be wrong? What else can I check?

 

Vivian

QuoteReplyEditDelete

 

 

2010-04-29 03:40:28     Re: uBoot loading problem with LdrViewer

Mike Frysinger (UNITED STATES)

Message: 89027   

 

your screenshot shows you told ldrviewer to load nothing.  reset the loader file address field to 0.

QuoteReplyEditDelete

 

 

2010-04-29 04:21:03     Re: uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 89030   

 

Hi Mike

 

The Loader File Address Field was 0 before the "Send DXE" button was pressed. When it is "done" with the upload, that addres field have changed, probably showing the ending address of the upload. But, as jou compare the 2 images, I don't get that "hex" response after the file was uploaded. Only the "Autobaud" response before the upload.

 

Vivian

QuoteReplyEditDelete

 

 

2010-04-29 04:23:52     Re: uBoot loading problem with LdrViewer

Mike Frysinger (UNITED STATES)

Message: 89031   

 

we dont have anything to do with the LdrViewer app.  if it works for you, great.  if not, then the only documentation is in the wiki and you're on your own.

 

you really should be using a real system with ldr-utils.

QuoteReplyEditDelete

 

 

2010-05-10 05:57:26     Re: uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 89280   

 

Hi Mike

 

It seems that LdrViewer is not the cause of the problem:

 

I have soldered another PCB, loaded uBoot successfully with a reply after the upload, and I'm able to reach the bfin> prompt through Hyperterminal. The only difference is that last time when I reached this point, I ran the "mtest" command.. After that Blackfin Failed to reply after uBoot was uploaded again.

 

Any idea why this happended? And why the "mtest" command did this? I need to recover this PCB as I have only components to build 3 units.

 

Vivian

QuoteReplyEditDelete

 

 

2010-05-10 11:05:06     Re: uBoot loading problem with LdrViewer

Mike Frysinger (UNITED STATES)

Message: 89284   

 

mtest merely reads/writes external memory.  if your hardware cant handle that, there's nothing to be done in software other than verify your SDRAM timings in the board config.

QuoteReplyEditDelete

 

 

2010-05-10 11:41:40     Re: uBoot loading problem with LdrViewer

Vivian de Meillon (SOUTH AFRICA)

Message: 89288   

 

Hi Mike

 

That is true. It tested the top and bottom addresses byte for byte at a time. After a while, I disconnected the power to the board, as I couldn't stop/abort the test. Starting up again, this is where the problem started. I don't know where to look anymore. I will check the SDRAM timing, but that is the same as the dev board.; and mtest would have given me some error that it can't read/write from/to SDRAM.

 

I even jumped in with a osciloscope to see if I find something strange. Nothing. I'm dumb struck...

 

Any idees what to look for?

 

Vivian

Outcomes