2010-04-19 23:19:12     serial flash problem on BF537 EZ-Kit lite

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2010-04-19 23:19:12     serial flash problem on BF537 EZ-Kit lite

Bo Li (CHINA)

Message: 88604   

 

I'm working on BF537 EZ-Kit lite. I can only find U-boot(U-Boot 2008.10 (ADI-2009R1.1-rc1) (Dec  4 2009 - 03:22:14)) for BF537 STAMP, can this U-boot work well for my board? I got stucked when I probe the Serial Flash by 'sf probe 1'. Problem is as followed:

 

bfin> sf probe 1

SF: Got idcode ff ff ff

SF: Unsupported manufacturer FF

Failed to initialize SPI flash at 0:1

bfin> sf probe 2

SF: Got idcode ff ff ff

SF: Unsupported manufacturer FF

Failed to initialize SPI flash at 0:2

 

I find the serial flash on my board is M29W320DB, which is not in the supporting list. I want to know how did you fixed this problem. Any advice will be highly welcome and appreciated.

 

Regards,

 

Libo

QuoteReplyEditDelete

 

 

2010-04-19 23:21:19     Re: serial flash problem on BF537 EZ-Kit lite

Mike Frysinger (UNITED STATES)

Message: 88605   

 

the BF537-STAMP and BF537-EZKIT are the same board and thus use the same binary.

 

there is no serial flash on the BF537-EZKIT.  the part you listed is not a serial flash, it's a parallel flash, and it works just fine with u-boot.

QuoteReplyEditDelete

 

 

2010-04-20 04:06:09     Re: serial flash problem on BF537 EZ-Kit lite

Bo Li (CHINA)

Message: 88625   

 

I'm sorry I havn't seen the same former thread. And thank you, I was misled before. I'll check if I can handle it.

Attachments

    Outcomes