2010-01-29 11:34:54     U-Boot in NAND Flash

Document created by Aaronwu Employee on Sep 25, 2013
Version 1Show Document
  • View in full screen mode

2010-01-29 11:34:54     U-Boot in NAND Flash

Christopher Harrsen (UNITED STATES)

Message: 85336   

 

Hi,

 

I have 2 boards. One board uses the Numonyx/ST NAND01GW3B2C NAND Flash and a BF526. I have U-BOOT loaded in the NAND flash and I boot from NAND flash without issue.

 

On the second board I have the MT29F4G08AAC NAND Flash and the BF525 (Rev 0.2). I use the same options when building U-BOOT but when I try to boot from NAND flash the board just hangs. I have verified that the nand interface works as I have been able to program u-boot into NAND.

 

Has anyone used the MT29F4G08AAC? Any issues? Any suggestions?

 

Thanks,

 

Chris

QuoteReplyEditDelete

 

 

2010-01-29 11:38:01     Re: U-Boot in NAND Flash

Mike Frysinger (UNITED STATES)

Message: 85337   

 

we've only tested ADI boards with booting out of NAND flash.  while any NAND flash that works with the on-chip NAND controller should work with the same, it doesnt mean there arent latent bugs.

 

can you connect JTAG to see where it's hung ?  what about booting over the UART and probing the flash from the command line ?

QuoteReplyEditDelete

 

 

2010-01-29 11:57:07     Re: U-Boot in NAND Flash

Christopher Harrsen (UNITED STATES)

Message: 85339   

 

Hi Mike,

 

We have been able to boot u-boot over the spi interface (from spi flash) and then boot the kernel out of the NAND flash. We can then use the NAND flash as expected.

 

We have the following when building u-boot:

 

CONFIG_BFIN_NFC_NO_HW_ECC = 0 (not set)

 

CONFIG_BFIN_NFC_BOOTROM_ECC=1 (set)

 

Regards,

 

Chris

Attachments

    Outcomes