2009-12-07 16:32:20     cp,b command missing in u-boot

Document created by Aaronwu Employee on Sep 24, 2013
Version 1Show Document
  • View in full screen mode

2009-12-07 16:32:20     cp,b command missing in u-boot

Bruce Stough (UNITED STATES)

Message: 83178   

 

I am attempting to update the u-boot image on my BF537 board.

 

I transfered the current u-boot.bin using tftp, and executed it from the old u-boot with the go 0x1000000 command.

 

 

 

I then erased the flash memory using the

 

       erase 0x20000000 0x200fffff

 

command, which reported 'Erased 23 sectors'.

 

I then tried the command

 

       cp.b 0x1000000 0x20000000 $(filesize)

 

as documented, but only got a 'Usage:  cp      - memory copy' message.  While the 'help' command lists 'cp', there does not appear to be a 'cp,b' command.

 

 

 

I think I am in trouble because the original u-boot is erased.  Is there a way to get 'cp,b' to work here?

QuoteReplyEditDelete

 

 

2009-12-07 16:52:10     Re: cp,b command missing in u-boot

Mike Frysinger (UNITED STATES)

Message: 83180   

 

cp.b isnt missing, you're just incorrectly using $(filesize).  env vars are not automatically retained acroess execution.  either load it again or set filesize manually.

QuoteReplyEditDelete

 

 

2009-12-07 18:57:45     Re: cp,b command missing in u-boot

Bruce Stough (UNITED STATES)

Message: 83181   

 

Mike,

 

Thank you very much!  I reloaded the u-boot binary and everything worked fine.  I was able to reboot with the new version!

 

The warning message had me confused.

QuoteReplyEditDelete

Attachments

    Outcomes