2009-09-03 00:12:59     CUSTOM BF527 BOARD UBOOT PROBLEM ABOUT EMAC

Document created by Aaronwu Employee on Sep 24, 2013
Version 1Show Document
  • View in full screen mode

2009-09-03 00:12:59     CUSTOM BF527 BOARD UBOOT PROBLEM ABOUT EMAC

dapeng wangdapeng (CHINA)

Message: 79504   

 

hi,guys!

 

i made a custom bf527 board ,and the EMAC part is exactly the same as  the ADSP-527 EZ-KIT Lite's SCHEMATIC,the RMII PHY schematic(LAN8700).

 

my uboot version is u-boot-1.1.6-2008R1.5.

 

there is a bfin_mac.c in  uboot/drivers, I find this is for BF537 ,can i directly use it to drive my uboot?

 

or ,where can i find a proper driver?

 

thanks!

QuoteReplyEditDelete

 

 

2009-09-03 00:41:08     Re: CUSTOM BF527 BOARD UBOOT PROBLEM ABOUT EMAC

Mike Frysinger (UNITED STATES)

Message: 79505   

 

use the 2009R1 release

 

also, there is no need to use all caps in your posts

QuoteReplyEditDelete

 

 

2009-09-03 04:43:42     Re: CUSTOM BF527 BOARD UBOOT PROBLEM ABOUT EMAC

dapeng wangdapeng (CHINA)

Message: 79515   

 

Hi Mike!

 

Thanks, I wil try that!

QuoteReplyEditDelete

 

 

2009-09-03 23:29:30     Re: CUSTOM BF527 BOARD UBOOT PROBLEM ABOUT EMAC

dapeng wangdapeng (CHINA)

Message: 79596   

 

hi mike:

 

I tried 2009R1 release. Also , I compiled it with 2009 toolchains successfully. But I couldn't run the u-boot.bin or u-boot.ldr on my board.

 

I follow the same steps as in 2008R1.5, and configured corresponding hardwares such as SDRAM, FLASH in .h file.

 

then the board directory and the top files :Makefile MAKEALL MAINTAINERS.

 

did I miss something important?

 

I use ADSP-BF527C BBCZ-ENG 0.0.

 

thanks

 

bf527.h

QuoteReplyEditDelete

 

 

2009-09-04 00:29:07     Re: CUSTOM BF527 BOARD UBOOT PROBLEM ABOUT EMAC

Mike Frysinger (UNITED STATES)

Message: 79597   

 

http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:debugging

Attachments

Outcomes