2009-07-07 04:23:14     custom u-boot development query

Document created by Aaronwu Employee on Sep 24, 2013
Version 1Show Document
  • View in full screen mode

2009-07-07 04:23:14     custom u-boot development query

Harbhajan Singh (INDIA)

Message: 76879   

 

Hi,

 

I am working with the BF527 Custom board. I am working on developing the custom u-boot. Boot mode Is the default mode (0001)

 

When I flashed the customized u-boot.ldr file into the flash it is not booting and I can not connect the jtag and see what is happening,

 

it says some error in opening the session. I need to spend some time in erasing the flash.

 

 

 

Is there any way to develop/get the the basic u-boot file for any custom board with blackfin processor specific like for BF533 and later I can verify the developed u-boot file using u-boot.bin fle and go command. And later I can flash the final u-boot into the custom board.

 

 

 

Are there any procedure and what things need to be taken care for smooth working with u-boot.

 

The flash chip on my custom hardware and the flash chip on the BF527 Ezkit are different.

 

Please advise

QuoteReplyEditDelete

 

 

2009-07-07 08:05:06     Re: custom u-boot development query

Robin Getz (UNITED STATES)

Message: 76884   

 

Harbhajan:

 

Can you change the Bmode pins on your board (to Load U-Boot over serial?)

 

 

 

>I flashed the customized u-boot.ldr file into the flash

 

How?

 

 

 

>I can not connect the jtag and see what is happening,

 

It is unable to connect (you have tried), or you can't make it work, or you have not tried?

QuoteReplyEditDelete

 

 

2009-07-07 08:49:06     Re: custom u-boot development query

Harbhajan Singh (INDIA)

Message: 76887   

 

Hi Robin,

 

Yes, I can change the boot mode but I want to make it work with default boot

mode (0001). I flashed the u-boot.ldr file into the flash chip using JTAG

and developed flash driver.

The Flash Programmer utility wont work with the Flash chip on the custom

board.

 

After flashing wrong u-boot code (Boot mode 0001). I could not connect the

JTAG and open the VDSP session. I changed the boot mode to (0000) IDLE and

then I am able to connect the JTAG and erased the flashed wrong data.

QuoteReplyEditDelete

 

 

2009-07-07 09:33:00     Re: custom u-boot development query

Robin Getz (UNITED STATES)

Message: 76888   

 

Harbhajan:

 

>VDSP session.

 

I stopped reading - and can't help.

 

Use an open source tool (like urjtag, gdbproxy with an gnICE, or boot from UART with the ldr-utils) - or go ask the VDSP support group.

 

-Robin

QuoteReplyEditDelete

 

 

2009-07-07 14:38:19     Re: custom u-boot development query

Mike Frysinger (UNITED STATES)

Message: 76894   

 

have you tried booting over the UART ?

https://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:loading

 

or perhaps debugging it:

https://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:debugging

Attachments

    Outcomes