2009-03-19 01:31:09     u-boot hangs up

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2009-03-19 01:31:09     u-boot hangs up

rohi sivaswamy (INDIA)

Message: 71228   

 

Hi All,

 

im facing a issue in u-boot for bf533.

 

it hangs in udelay() function.the cycle count is not getting updated. it seems to be  zero always.

 

please help me in this regard..

 

 

QuoteReplyEditDelete

 

 

2009-03-19 01:43:02     Re: u-boot hangs up

Mike Frysinger (UNITED STATES)

Message: 71229   

 

that indicates you've done something wrong like resetting the SYSCFG register.  u-boot programs it properly in early init code (start.S).

QuoteReplyEditDelete

 

 

2009-03-19 06:03:02     Re: u-boot hangs up

rohi sivaswamy (INDIA)

Message: 71262   

 

the u-boot which we are using now is working in another bf533 board.

 

for our board it is not working.

 

wat may be the problem..??

 

any hardware problem????

 

can u help us in this regard...

QuoteReplyEditDelete

 

 

2009-03-19 06:12:50     Re: u-boot hangs up

rohi sivaswamy (INDIA)

Message: 71263   

 

where we have to reset the SYSCFG register??

 

in cpu/bf533/interrupts.c

 

here,

 

asm volatile (" %0 = CYCLES;": "=r"(start));

 

         do {

 

            asm volatile (" %0 = CYCLES; ": "=r"(stop));

 

 

        } while (stop - start < delay);

 

 

CYCLES are not getting updated and u-boot hangs here...

QuoteReplyEditDelete

 

 

2009-03-19 06:20:04     Re: u-boot hangs up

Mike Frysinger (UNITED STATES)

Message: 71264   

 

like i said, check the SYSCFG register to make sure CCEN is set

QuoteReplyEditDelete

 

 

2009-03-20 08:06:25     Re: u-boot hangs up

rohi sivaswamy (INDIA)

Message: 71301   

 

Hi,

 

SYSCFG_CCEN is enabled.

 

eventhough we are facing the same issue.

 

 

QuoteReplyEditDelete

 

 

2009-03-20 08:45:16     Re: u-boot hangs up

Mike Frysinger (UNITED STATES)

Message: 71302   

 

if CCEN is set in SYSCFG, but CYCLES isnt incrementing, that indicates your jtag is getting in the way (i.e. VDSP)

QuoteReplyEditDelete

 

 

2009-03-20 08:54:53     Re: u-boot hangs up

rohi sivaswamy (INDIA)

Message: 71304   

 

please tell me clearly.

QuoteReplyEditDelete

 

 

2009-03-20 21:55:44     Re: u-boot hangs up

Robin Getz (UNITED STATES)

Message: 71322   

 

Rohi:

 

What JTAG debugger are you using to debug things?

 

The only thing we support - is the gnICE + gdb.

QuoteReplyEditDelete

Attachments

    Outcomes