2009-03-03 08:08:29     CM-BF537E: not seeing kernel command line

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2009-03-03 08:08:29     CM-BF537E: not seeing kernel command line

Ryan Mitchley (SOUTH AFRICA)

Message: 70282   

 

Newbie question: I've got u-boot successfully booting uCLinux from a TFTP server. I'm now trying to modify the u-boot build so that this happens automatically. I'm flashing the u-boot hex loader using VDSP.

 

I've set

 

#define CONFIG_BFIN_BOOT_MODE       BFIN_BOOT_PARA

#define CONFIG_UART_CONSOLE 0

#define ADI_CMDS_NETWORK 1

 

in cm-bf537e.h

 

I would like u-boot to pass the IP configuration to the kernel using the command line. However, the command line is just reading "console=ttyBF0,115200". There is a kernel panic because the root fs is not being passed in (I think it should be "root=/dev/mtdblock0 rw")

 

As far as I can see, the correct commands are being created in bfin_adi_common.h (CONFIG_BOOTARGS, NETWORK_ENV_SETTINGS, etc.), however these are somehow not making it to the kernel command line.

 

Could someone more familiar with the build setup maybe advise what I should check? Thanks for any advice.

QuoteReplyEditDelete

 

 

2009-03-03 13:52:27     Re: CM-BF537E: not seeing kernel command line

Mike Frysinger (UNITED STATES)

Message: 70297   

 

did you compile the command line into the kernel ?

 

how exactly are you booting (what image file are you using) ?

Attachments

    Outcomes