2009-02-27 20:03:18     Error Compiling U-boot 2009.01

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2009-02-27 20:03:18     Error Compiling U-boot 2009.01

Pawel Pastuszak (CANADA)

Message: 70125   

 

Hi Guys,

 

I am trying to get the new u-boot compile to be able move couple bf537 custom board over to it.

 

All of the board i have are base of SPI MASTER mode.

 

So i modifyed stamp to compile for SPI MASTER mode

--- a/u-boot-2009.01/include/configs/bf537-stamp.h

+++ b/u-boot-2009.01/include/configs/bf537-stamp.h

@@ -12,7 +12,7 @@

  * Processor Settings

  */

#define CONFIG_BFIN_CPU             bf537-0.2

-#define CONFIG_BFIN_BOOT_MODE       BFIN_BOOT_BYPASS

+#define CONFIG_BFIN_BOOT_MODE       BFIN_BOOT_SPI_MASTER

 

============================================

 

 

 

And i get the following error:

 

ap -o u-boot cpu/blackfin/system_map.o

bfin-uclinux-objcopy -O srec u-boot u-boot.srec

bfin-uclinux-objcopy --gap-fill=0xff -O binary u-boot u-boot.bin

tools/envcrc common/env_common.o --binary > env-ldr.o

bfin-uclinux-ldr -T bf537-0.2 -c u-boot.ldr u-boot -J --bmode SPI_MASTER --use-vmas --initcode cpu/blackfin/initcode.o --punchit $((0x4000)):$((0x2000)):env-ldr.o

create: invalid option -- J

bfin-uclinux-ldr: Unknown option 'J' or argument missing

 

Backtrace:

bfin-uclinux-ldr[0x8049c6a]

bfin-uclinux-ldr[0x804a5c2]

bfin-uclinux-ldr[0x804abed]

/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0x40068450]

bfin-uclinux-ldr(read+0x49)[0x8049471]

make: *** [u-boot.ldr] Error 1

 

 

My toolchain is:

 

pawel@pawel-laptop:/development/bf-u-boot/u-boot-2009.01$ bfin-uclinux-gcc -v

Using built-in specs.

Target: bfin-uclinux

Configured with: /usr/src/packages/BUILD/blackfin-toolchain-08r1/../gcc-4.1/configure --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --target=bfin-uclinux --prefix=/opt/uClinux/bfin-uclinux --enable-threads=posix --with-sysroot=/opt/uClinux/bfin-uclinux/bfin-uclinux/runtime --disable-libstdcxx-pch --disable-symvers --disable-libssp --disable-libffi --enable-clocale=generic --enable-version-specific-runtime-libs --enable-__cxa_atexit

Thread model: posix

gcc version 4.1.2 (ADI svn)

 

 

 

 

Any ideas?

 

 

 

 

QuoteReplyEditDelete

 

 

2009-02-27 22:17:18     Re: Error Compiling U-boot 2009.01

Mike Frysinger (UNITED STATES)

Message: 70126   

 

please read the FAQ.  if you want to build trunk code, you need trunk tools.

QuoteReplyEditDelete

 

 

2009-02-28 11:09:39     Re: Error Compiling U-boot 2009.01

Pawel Pastuszak (CANADA)

Message: 70164   

 

Thanks Mike,

 

 

 

I discovered this later that night that need the newer toolchain.

Attachments

    Outcomes