2009-01-28 10:42:31     u-boot via uart error

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2009-01-28 10:42:31     u-boot via uart error

igor lektorov (BELARUS)

Message: 68483   

 

I conigured u-boot 1.3.2 for bf537-stamp. After compile I can't load u-boot.ldr via ldr-utils. Log is below. I using last ldr-utils from svn. u-boot 1.1.6 does not have this problem. Where is errors?

 

 

 

Loading LDR u-boot.ldr ... LDR block 1: [off:0x00000000] [header(0xa): 01505bffffffad 0000ffffffa0ffffffff 0000] [data(0xffa00000)]

ldr: malloc(4288675840) returned NULL!: Cannot allocate memory

 

Backtrace:

ldr[0x4020a7]

ldr[0x402881]

ldr[0x406675]

ldr[0x403663]

/lib/libc.so.6(__libc_start_main+0xe6)[0x7ff2bcbe4466]

ldr[0x401fa9]

 

 

QuoteReplyEditDelete

 

 

2009-01-28 14:40:22     Re: u-boot via uart error

Mike Frysinger (UNITED STATES)

Message: 68492   

 

u-boot-1.3.2 is not supported.  basically that error is telling you the LDR is invalid.

QuoteReplyEditDelete

 

 

2009-01-29 05:08:47     Re: u-boot via uart error

igor lektorov (BELARUS)

Message: 68507   

 

Thanks a lot! I probably use 2009.01.

QuoteReplyEditDelete

 

 

2009-01-29 11:39:38     Re: u-boot via uart error

Mike Frysinger (UNITED STATES)

Message: 68521   

 

dont go downloading random packages from the u-boot website.  only versions that are in our svn trunk are supported (and yes, 2009.01 is in there).

Attachments

    Outcomes