2008-09-16 09:46:38     u-boot for TCM-BF537

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-09-16 09:46:38     u-boot for TCM-BF537

Miquel Soler i Mir (SPAIN)

Message: 62256   

 

Hello.

 

I'm working with TCM-BF537 and CM-BF537E from bluetechnix.

 

With CM-BF537E I don't have any problem, I'm using the 1.1.6 version.

 

For TCM-BF537, it's not port to 1.1.6 version and the path (from bluetechnix) is for 1.1.3 (2006R2)

 

I downloaded the u-boot-1.1.3 (2006R2) and applied the path from bluetechnix.

 

I have and error when I try to compile. The system answer me this:

 

$make tcm-bf537_config

 

$make

 

...................................................

 

s -c -o stubs.o stubs.c

bfin-uclinux-ar cr libstubs.a  stubs.o

bfin-uclinux-ld -g  -Ttext 0x1000 \

                -o hello_world -e _hello_world hello_world.o libstubs.a \

                -L/opt/uClinux/bfin-uclinux/lib/gcc/bfin-uclinux/4.1.2 -lgcc

libstubs.a(stubs.o): In function `app_startup':

/home/mikimonster/src/Programs/u-boot/u-boot_1.1.3/examples/stubs.c:164: undefined reference to `_bss_start'

/home/mikimonster/src/Programs/u-boot/u-boot_1.1.3/examples/stubs.c:164: undefined reference to `_bss_start'

make[1]: *** [hello_world] Error 1

make[1]: Leaving directory `/home/mikimonster/src/Programs/u-boot/u-boot_1.1.3/examples'

make: *** [examples] Error 2

mikimonster@miki-toshiba:~/src/Programs/u-boot/u-boot_1.1.3$

 

I try with TCM-BF537 and STAMP ans say me the same error.

 

I'm using the toolchain 2008R1. Can be this the problem?

 

Somebody is working with the port of TCM-BF537 to 1.1.6 ?

 

Thanks

 

Miquel Soler i Mir

TranslateQuoteReplyEditDelete

 

 

2008-09-16 13:53:29     Re: u-boot for TCM-BF537

Mike Frysinger (UNITED STATES)

Message: 62259   

 

only the latest u-boot release is supported.  if you get errors on older releases, you get to figure it out.

 

TCM-BF537 support is already in trunk u-boot.

QuoteReplyEditDelete

 

 

2008-12-18 05:02:54     Re: u-boot for TCM-BF537

Patrick Hotz (GERMANY)

Message: 66856   

 

Hi,

 

i have also problems with the TCM.VF537 board.

I have the USB-ETH extender board with an Micrel KS8721 ehternet chip.

I want to download the uImage over network but i cant use this.

The "ping" reports "host is not alive" although i have connected the ethernet to the modul.

The jellow LED on the network connector shiners and the green blink sometimes, so i think the chip is working.

Is there any special configuration needed to use ethernet with the TCM-BF537 modul?

 

Regards Patrick

TranslateQuoteReplyEditDelete

 

 

2008-12-18 09:31:28     Re: u-boot for TCM-BF537

Mike Frysinger (UNITED STATES)

Message: 66863   

 

you'll have to ask the bluetechnix guys

Attachments

    Outcomes