2008-11-07 06:55:17     u-boot not coming up of BF526 ezkit board

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-11-07 06:55:17     u-boot not coming up of BF526 ezkit board

deepthi kiran (INDIA)

Message: 64826   

 

HI,

 

  I was trying to bring up u-boot on BF526 Ezkit, I flashed the u-boot.ldr through flash programmer of VDSP, flashing is happening but booting is not happening, I checked the bootmode(1) it is fine.I downloaded the prebuit images of u-boot from the blackfin.uclinux.org site (u-boot-bf526-ezkit-para-2008R1.5.ldr,u-boot-bf526-ezkit-spi-2008R1.5.ldr,u-boot-bf526-ezkit-uart-2008R1.5.ldr and tried booting from parallel flash, serial flash and UART, nothing is working, I checked runnng the diag code of flash and is working fine and even UART is working fine. I even tried flashing BF526_EZKIT_POST.ldr file, but even post power on test is not booting, So please help to solve this issue.

 

Thanks and Regards

 

Deepthi

QuoteReplyEditDelete

 

 

2008-11-07 07:00:55     Re: u-boot not coming up of BF526 ezkit board

Mike Frysinger (UNITED STATES)

Message: 64827   

 

if you are using a newer rev of the board, you need to build u-boot from svn trunk.  they changed the sdram part on the board and it has different timings.

QuoteReplyEditDelete

 

 

2008-11-07 07:27:20     Re: u-boot not coming up of BF526 ezkit board

deepthi kiran (INDIA)

Message: 64829   

 

Thanks mike,do  I need to down load u-boot-trunk-svn.src.tar.bz2 which is there in the Nightly Snapshots ?

 

But when we give download file size it is showing only 1 byte, where is the complete source file?

QuoteReplyEditDelete

 

 

2008-11-07 07:39:43     Re: u-boot not coming up of BF526 ezkit board

Mike Frysinger (UNITED STATES)

Message: 64830   

 

you have to fetch from svn yourself

 

there are some examples here:

http://docs.blackfin.uclinux.org/doku.php?id=developing_with_blackfin_live_sources

Attachments

    Outcomes