2008-10-22 15:35:33     loading BF548 via UART: Bad file descriptor

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-10-22 15:35:33     loading BF548 via UART: Bad file descriptor

Dong Ye (UNITED STATES)

Message: 64067   

 

Trying to load u-boot via UART to BF548 EZ-KIT. Following the directions in

http://docs.blackfin.uclinux.org/doku.php?id=hw:boards:bf548-ezkit

http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:loading

 

I went through successfully with

- Install toolchain (version 08r1.5-14)

- Build U-Boot (version 1.1.6-2008R1.5)

- Set BMODE=7 via BOOT dial and press RESET

 

But failed in loading the u-boot.ldr file via ttyS0 using ldr-utils. Got the following messages:

 

$ bfin-uclinux-ldr -l u-boot.ldr /dev/ttyS0 && kermit -l /dev/ttyS0 -b 57600 -C connect

Loading LDR u-boot-1.1.6/u-boot.ldr ... OK!

Opening /dev/ttyS0 ... OK!

Configuring terminal I/O ... OK!

Trying to send autobaud ... OK!

Trying to read autobaud ... OK!

Checking autobaud ... Failed: wanted {0xBF,..,..,0x00} but got {0x00,[0x00],[0x00],0x00}

Failed: Bad file descriptor

 

From the troubleshooting section, it seems that my connection is OK since I passed the read autobaud stage. Please help with how to proceed forward.

 

 

Thanks,

Dong

 

 

QuoteReplyEditDelete

 

 

2008-10-22 15:47:44     Re: loading BF548 via UART: Bad file descriptor

Mike Frysinger (UNITED STATES)

Message: 64068   

 

if the autobaud check failed, then it usually means your connection is not OK.  check the UART settings on the board and check your serial cable.

Attachments

    Outcomes