2008-10-09 07:17:26     TFTP:ing U-Boot fails

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-10-09 07:17:26     TFTP:ing U-Boot fails

Jere Mäkelä (FINLAND)

Message: 63331   

 

I've got an 533 stamp and 537 ezkits. I have built new u-boot versions and placed them on /tftpboot.

 

TFTP works when invoked within the Linux host but does not work with either target boards.

 

here's what it shows after printenv and tftp commands:

 

 

 

bootargs=root=/dev/mtdblock0 rw earlyprintk=serial,uart0,57600 console=ttyBF0,57600

bootcmd=run ramboot

bootdelay=5

baudrate=57600

loads_echo=1

rootpath=/romfs

netmask=255.255.255.0

hostname=bf533-stamp

loadaddr=0x1000000

update=tftp $(loadaddr) $(ubootfile);protect off 0x20000000 0x2003FFFF;erase 0x20000000 0x2003FFFF;cp.b $(loadaddr) 0x20000000 $(filesize)

addip=set bootargs $(bootargs) ip=$(ipaddr):$(serverip):$(gatewayip):$(netmask):$(hostname):eth0:off

ramargs=set bootargs root=/dev/mtdblock0 rw earlyprintk=serial,uart0,57600 console=ttyBF0,57600

ramboot=tftp $(loadaddr) uImage;run ramargs;run addip;bootm

nfsargs=set bootargs root=/dev/nfs rw nfsroot=$(serverip):$(rootpath),tcp,nfsvers=3

nfsboot=tftp $(loadaddr) vmImage;run nfsargs;run addip;bootm

flashboot=bootm 0x20100000

ethaddr=00:E0:22:FE:06:B4

serverip=192.168.1.2

ipaddr=192.168.1.3

ubootfile=u-boot_533.bin

gatewayip=192.168.1.1

stdin=serial

stdout=serial

stderr=serial

 

Environment size: 944/8188 bytes

bfin> tftp 0x1000000 u-boot_533.bin

TFTP from server 192.168.1.2; our IP address is 192.168.1.3

Filename 'u-boot_533.bin'.

Load address: 0x1000000

Loading: T T T T

Abort

bfin>

 

I have tried cross-over cables and with a switch with no difference.

 

Linux host address is 192.168.1.2.

 

 

 

Jere

QuoteReplyEditDelete

 

 

2008-10-09 12:34:56     Re: TFTP:ing U-Boot fails

Frank Van Hooft (CANADA)

Message: 63343   

 

Looks like your u-boot network settings are reasonable, so my first guess would be that your board is unable to connect to your TFTP server. Do you have a firewall or something running on your tftp server machine? Is another PC on the network able to connect to your tftp server PC? Are you 100% sure that the u-boot_533.bin file is actually in the tftp server directory?

QuoteReplyEditDelete

 

 

2008-10-09 13:12:03     Re: TFTP:ing U-Boot fails

Jere Mäkelä (FINLAND)

Message: 63347   

 

Thanks,

 

I checked my services and "iptables" was on, which blocked TFTP.

 

Now it works,

 

 

 

Jere

Attachments

    Outcomes