2008-08-07 05:57:57     cannot build bf548 ez-kit: linker error

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-08-07 05:57:57     cannot build bf548 ez-kit: linker error

Rutger Hofman (NETHERLANDS)

Message: 60093   

 

I cannot build u-boot from svn with the current stable or snapshoot toolchains:

 

bfin-uclinux-ldr -T bf548-0.0 -f -c u-boot.ldr u-boot --bmode para --use-vmas --initcode cpu/blackfin/initcode.o --punchit $(((0x20002000 - 0x20000000))):$((0x2000)):env-ldr.o --dma 6

create: unrecognized option `--bmode'

bfin-uclinux-ldr: Unknown option '?' or argument missing

 

Backtrace:

bfin-uclinux-ldr[0x8049c6a]

bfin-uclinux-ldr[0x804a5c2]

bfin-uclinux-ldr[0x804abed]

/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0xb7dcd450]

bfin-uclinux-ldr(read+0x49)[0x8049471]

make: *** [u-boot.ldr] Error 1

 

I saw in bug 4198 that somebody else met the same problem. This issue was closed this way:

 

Submitted By: Mike Frysinger

Adddate: 2008-06-25 20:15:37

backported the relevant ldr-utils changes to the branch

 

But I don't know which way to proceed.

Which branch? Is this a branch of the toolchain? If so, which?

Should I check out that branch from toolchain svn and build the toolchain myself?

Or is there a tarball with a working toolchain?

 

I can build a u-boot release, but I am interested in the latest goodies like NAND flash booting.

 

Rutger Hofman

VU Amsterdam

 

QuoteReplyEditDelete

 

 

2008-08-07 14:13:41     Re: cannot build bf548 ez-kit: linker error

Robin Getz (UNITED STATES)

Message: 60118   

 

Rutger:

 

Trunk projects require Trunk toolchains, and the machine that builds snaphots died a few months ago.

 

you can build it yourself:

 

https://docs.blackfin.uclinux.org/doku.php?id=developing_with_blackfin_live_sources

Attachments

    Outcomes