2008-07-28 06:02:26     dm9000 not pinging

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-07-28 06:02:26     dm9000 not pinging

roopesh motewar (INDIA)

Message: 59472   

 

hi ,

 

i mounted bf532,spi  flash, dm9000, cpld and ram on board (from devid raw)

 

my boot loadrer working fine.

 

while pinging bf1 detect the dm9000 ic but unable to ping the gateway

 

i checked out all connection it seems to be ok

 

while pinging the network switch glows the ack led.

 

any one can help me out to solve this probleam

 

the console output is as:

 

ip04>U-Boot 1.1.5 (Jul 22 2008 - 10:58:24)

 

CPU:   ADSP BF532 Rev.: 0.5

Board: IP04 IP-PBX

       http://www.rowetel.com/ucasterisk/ip04.html

Clock: VCO: 400 MHz, Core: 400 MHz, System: 133 MHz

SDRAM: 64 MB

*** Warning - bad CRC, using default environment

 

In:    serial

Out:   serial

Err:   serial

No NAND device found!!!

0 MiB

DM9000#0

starting from spi flash

Hit any key to stop autoboot:  0

 

EEPROM @0x0 read: addr 0x01000000  off 0x30000  count 0x110000

 

done

## Booting image at 01000000 ...

Bad Magic Number

ip04>

ip04>

ip04>ping 192.168.1.1

dm9000 i/o: 0x20100000, id: 0x90000a46

MAC: 02:80:ad:20:31:b8

operating at 100M full duplex mode

Using DM9000#0 device

ping failed; host 192.168.1.1 is not alive

ip04>ping 192.168.1.1

dm9000 i/o: 0x20100000, id: 0x90000a46

MAC: 02:80:ad:20:31:b8

operating at 100M full duplex mode

Using DM9000#0 device

ping failed; host 192.168.1.1 is not alive

 

thanks

 

roopesh

 

 

QuoteReplyEditDelete

 

 

2008-07-28 06:22:42     Re: dm9000 not pinging

Mike Frysinger (UNITED STATES)

Message: 59475   

 

are you sure 192.168.1.1 is a valid IP and it responds to pings ?  pick a machine that pings fine from other linux machines and then ping that with u-boot.  review the networking documents in our documentation wiki for further troubleshooting tips.

QuoteReplyEditDelete

 

 

2008-07-29 02:24:27     Re: dm9000 not pinging

roopesh motewar (INDIA)

Message: 59505   

 

thanks

 

192.168.1.1 is our local network gateway ip address  i am having the ref. board from devid raw and it is able to ping 192.168.1.1 ip address i am using same set up to ping my board

 

ropesh motewar

 

 

QuoteReplyEditDelete

 

 

2008-07-29 02:53:36     Re: dm9000 not pinging

Mike Frysinger (UNITED STATES)

Message: 59508   

 

then put a packet sniffer on the other side of the board and make sure it is actually transmitting packets ... if it isnt, you should check your cables and hardware

Attachments

    Outcomes