2008-05-27 10:12:00     Problem with booting uboot over UART on BF527 Ezkit

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-05-27 10:12:00     Problem with booting uboot over UART on BF527 Ezkit

Ashish Gupta (INDIA)

Message: 56306   

 

Dear Mike/Robin

 

I am facing problem with booting uboot on BF527 EZKIT over UART.

 

I am using the u-boot-bf527-ezkit-uart-2008R1.ldr image downloaded from the latest release, I am able to use the LDR viewer ver 2 to transfer the image over the BF527 EZkit in BMODE 8 (boot over UART1) at Baud rate 115200 bps. Please see the screenshot image of the above process.

 

But I don't get a uboot promt as I hit enter on my terminal program (Hyper Terminal), I tried with both 115200 and 57600 as baud rates for Hyper Terminal.

 

Please indicate if my procedure is flawed.

 

Also, I was able to boot the 527EZkit from SPI Flash after it using VDSP with u-boot-bf527-ezkit-spi-2008R1.ldr from the same release.

 

regards

 

Ashish Gupta

 

Bangalore, India

 

 

 

 

 

 

 

LdrViewer.JPG

LdrViewer.JPG

QuoteReplyEditDelete

 

 

2008-05-28 03:17:41     Re: Problem with booting uboot over UART on BF527 Ezkit

Mike Frysinger (UNITED STATES)

Message: 56321   

 

the process for booting over the UART is documented here:

http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:loading

 

beyond that, we dont really use LdrViewer or VDSP or Windows tools

Attachments

    Outcomes