2008-05-01 22:51:21     how to port uboot image through jtag

Document created by Aaronwu Employee on Sep 18, 2013
Version 1Show Document
  • View in full screen mode

2008-05-01 22:51:21     how to port uboot image through jtag

a manjula (INDIA)

Message: 55359   

 

Hi,

 

 

 

     I want to port u-boot image to my new development board bf527.   I am able to load the u-boot image to

 

memory through jtag using this command

 

"memory load tftp://10.201.0.39/u-boot.bin bin 0x1000"

 

It is completing loading u-boot image to RAM successully.

 

After loading, it will display the tag as "image loaded  successfully:.

 

When I give command

 

"go 0x1000"

 

it is executing the command "go", and coming out of the command prompt without any error.

 

Please tell me how to see the image loaded  on the target board is working correctly or not.

 

 

 

Thanks in Advance,

 

Manjula

QuoteReplyEditDelete

 

 

2008-05-01 23:38:45     Re: how to port uboot image through jtag

Mike Frysinger (UNITED STATES)

Message: 55360   

 

you should be booting over the UART initially rather than messing around with JTAG

 

whether you can even access memory right away is up to whatever JTAG device you're using and whether you configured it to do so and with the right settings in the first place

QuoteReplyEditDelete

 

 

2008-05-02 09:58:11     Re: how to port uboot image through jtag

a manjula (INDIA)

Message: 55369   

 

Hi,

 

 

 

     I don't  have uart in our board.  Therefore I should run through jtag only . I am able to run the code in target

 

board but when I execute the same code, It will come out of command prompt, and I cann't see any

 

output from my code.

 

 

 

Thanks

 

Manjula

QuoteReplyEditDelete

 

 

2008-05-02 18:19:31     Re: how to port uboot image through jtag

Mike Frysinger (UNITED STATES)

Message: 55380   

 

then consult the documentation on how to debug it:

http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:debugging

Attachments

    Outcomes