2008-04-14 09:11:16     bf548-ezkit watchdog does not seem to work

Document created by Aaronwu Employee on Sep 17, 2013
Version 1Show Document
  • View in full screen mode

2008-04-14 09:11:16     bf548-ezkit watchdog does not seem to work

J.J. Krabbendam (NETHERLANDS)

Message: 54202    Hi,

 

I tried to check if the watchdog on bf548-ezkit is working for u-boot in 2008R1-RC8.

I have #define CONFIG_HW_WATCHDOG set in the config file and it seems that some code related to the watchdog has been enabled in the initcode.c file:

 

bfin-uclinux-objdump -d initcode.o

======

  ...

  b0:   4a e1 c0 ff     P2.H = 0xffc0;          /* (-64)        P2=0xffc0200c(-4186100) */

  b4:   40 e1 35 77     R0.H = 0x7735;          /* (30517)      R0=0x77350000(1999962112) */

  b8:   0a e1 04 02     P2.L = 0x204;           /* (516)        P2=0xffc00204(-4193788) */

  bc:   00 e1 00 94     R0.L = 0x9400;          /* (-27648)     R0=0x77359400(2000000000) */

  c0:   10 93           [P2] = R0;

  c2:   00 60           R0 = 0x0 (X);           /*              R0=0x0(  0) */

  c4:   e2 6f           P2 += -0x4;             /* ( -4) */

  c6:   10 97           W[P2] = R0;

  ...

======

 

 

But when I stay in u-boot and give the command:

md.w ffc00200 1, I get 0ad0

 

If I enable the watchdog by hand as follows, the system will reset after about 32 seconds.

====

mw.l ffc00204 ffffffff

mw.w ffc00200 0

====

 

Any comments?

 

Artis.

 

 

QuoteReplyEditDelete

 

 

2008-04-14 14:27:32     Re: bf548-ezkit watchdog does not seem to work

Mike Frysinger (UNITED STATES)

Message: 54206    if the system resets, it means watchdog wasnt properly built into your whole system as there is code throughout to pet it.  you should do `make clean` to make sure all of the objects are cleaned.

QuoteReplyEditDelete

 

 

2008-04-15 07:24:57     Re: bf548-ezkit watchdog does not seem to work

J.J. Krabbendam (NETHERLANDS)

Message: 54269    Thanks for your response.

I was working with several targets and forgot to actually update the u-boot with the newly compiled version.

As far as I can see it works OK.

 

 

Artis

Attachments

    Outcomes