2008-01-30 08:38:49     not loading u-boot on BF537-EZKit Lite Rev 1.4.

Document created by Aaronwu Employee on Sep 17, 2013
Version 1Show Document
  • View in full screen mode

2008-01-30 08:38:49     not loading u-boot on BF537-EZKit Lite Rev 1.4.

Anton Romanov (RUSSIAN FEDERATION)

Message: 50375    Dear colleagues! I load u-boot_stamp537_uart_boot.ldr to broad BF537-EZKit Lite Rev 1.4. with VisialDSP 4.5 Tools-Flash Programming (load driver, and programming ldr file). But, when i reset broad and load Windows HyperTerminal (Com1) I not see invitation from U-boot. What i do wrong? may be need other version of U-boot or need some spesial configuration. I am just a beginner, waiting for your help. Thanks.

QuoteReplyEditDelete

 

 

2008-01-30 09:13:26     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Mike Frysinger (UNITED STATES)

Message: 50376    you used the wrong LDR file

 

please review this document:

http://docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:loading

QuoteReplyEditDelete

 

 

2008-01-30 09:59:36     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Anton Romanov (RUSSIAN FEDERATION)

Message: 50377    I've read that page. I have loaded .hex file to flash and have the same result(not work). Could you tell me what file is correct? .hex or .ldr.hex ? I must compiling file myself or i can download file? If you have Enternet-link on correct file, give please. I have downloaded files from: http://blackfin.uclinux.org/gf/project/u-boot/frs

QuoteReplyEditDelete

 

 

2008-01-30 14:21:49     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Mike Frysinger (UNITED STATES)

Message: 50388    you flash the binary that corresponds to whatever boot mode you are using

 

what boot mode are you trying to use ?

QuoteReplyEditDelete

 

 

2008-01-31 06:53:55     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Anton Romanov (RUSSIAN FEDERATION)

Message: 50464    If you asking about "Boot Mode Select Switch", then 1 - Boot from 16-bit flash memory p.s. i trying load U-boot how write in "Initially Loading U-Boot"-"Visual DSP++ ADI ICE"

QuoteReplyEditDelete

 

 

2008-01-31 08:49:46     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Robin Getz (UNITED STATES)

Message: 50465    Anton:

 

Have a look at:

http://docs.blackfin.uclinux.org/doku.php?id=hw:boards:bf537-stamp#setting_up_the_stamp_hardware

 

item #2 - proper switch settings - yours isn't it.

 

-Robin

QuoteReplyEditDelete

 

 

2008-01-31 09:18:31     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Mike Frysinger (UNITED STATES)

Message: 50469    the UART ldr is only for booting *over the UART* ... if you arent booting that way, then dont use that LDR

QuoteReplyEditDelete

 

 

2008-01-31 10:25:22     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Anton Romanov (RUSSIAN FEDERATION)

Message: 50476    Thanks for help. but i think problems not with configuration board, because i construct uart.ldr file when compiling the simple example for VDSP (Uart_RS323_Hiper_Terminal , echo for com-port ) and then load uart.ldr to board. reset board and i see "welcome" from loading program and can work with it. so, when i load u-boot.ldr, nothing to work. loading u-boot have some features? i attempt many variations ... and did not know how to choose this problem.

QuoteReplyEditDelete

 

 

2008-01-31 10:28:22     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Anton Romanov (RUSSIAN FEDERATION)

Message: 50477    i load u-boot-1.1.6.tar.bz2 and construct u-boot.ldr file itself. but he not work too.

QuoteReplyEditDelete

 

 

2008-01-31 10:49:14     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Robin Getz (UNITED STATES)

Message: 50481    Anton:

 

You asked for help - I told you the answer. If you don't want to listen, and have things still not working - that is up to you.

 

The best thing you can do to have a successful Linux experience is put VDSP away - forget everything that you thought you knew about the Blackfin, and listen and follow the recommendations that you get on these forums. Linux does things much differently than VDSP.

 

-Robin

QuoteReplyEditDelete

 

 

2008-01-31 11:14:02     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Mike Frysinger (UNITED STATES)

Message: 50486    as Robin said, you're using the wrong bootmode.  you want bootmode 0 (which means bypass) and you do not want u-boot.ldr, you want u-boot.bin.

QuoteReplyEditDelete

 

 

2008-02-05 02:58:56     Re: not loading u-boot on BF537-EZKit Lite Rev 1.4.

Anton Romanov (RUSSIAN FEDERATION)

Message: 50669    working thanks!

Attachments

    Outcomes