FAQ: [#6958] Error building ALSA(2012)

Document created by Aaronwu Employee on Sep 12, 2013
Version 1Show Document
  • View in full screen mode

[#6958] Error building ALSA

Submitted By: Gilles Gameiro

Open Date

2012-01-18 17:27:41     Close Date

2012-03-09 02:49:29

Priority:

Medium     Assignee:

Vivi Li

Status:

Closed     Fixed In Release:

N/A

Found In Release:

2011R1     Release:

2011R1

Category:

uClinux-dist applications     Board:

EZKIT Lite

Processor:

BF527     Silicon Revision:

0.2

Is this bug repeatable?:

Yes     Resolution:

Rejected

Uboot version or rev.:

5c6d8a17c1056b7fcc2ad5c7d91481     Toolchain version or rev.:

74e1c1dd064b237896979cdcb4fce0

App binary format:

FDPIC     

Summary: Error building ALSA

Details:

 

Building on a ubuntu server for Blackfin 527 EZ_KIT_V2 checked out 2011R1 two days ago. pulled EVERYTHING of 2011R1 a few dats ago (Jan 17 - including toolchain and rebuilt all).

 

This looks like bug #3375 all over again?

 

Making install in mixer

Making install in simple

/bin/bash ../../../libtool   --mode=install /usr/bin/install -c   smixer-sbase.la smixer-ac97.la smixer-hda.la '/home/gilles/bfdev/uclinux-dist/staging/usr/lib/alsa-lib/smixer'

libtool: install: warning: relinking `smixer-sbase.la'

(cd /home/gilles/bfdev/uclinux-dist/lib/alsa-lib/build-alsa-lib-1.0.24/modules/mixer/simple; /bin/bash ../../../libtool  --silent --tag=CC --mode=relink bfin-linux-uclibc-gcc -g -O2 -W -Wall -pipe -Wall -g -O2 -mcpu=bf527-0.2 -lm -D_GNU_SOURCE -module -avoid-version -mcpu=bf527-0.2 -o smixer-sbase.la -rpath /usr/lib/alsa-lib/smixer sbase.lo ../../../src/libasound.la -inst-prefix-dir /home/gilles/bfdev/uclinux-dist/staging)

/usr/lib/libm.so: file not recognized: File format not recognized

collect2: ld returned 1 exit status

libtool: install: error: relink `smixer-sbase.la' with the above command before installing it

make[8]: *** [install-pkglibLTLIBRARIES] Error 1

make[7]: *** [install-am] Error 2

make[6]: *** [install-recursive] Error 1

make[5]: *** [install-recursive] Error 1

make[4]: *** [install-recursive] Error 1

make[3]: *** [all] Error 2

make[2]: *** [alsa-lib] Error 2

make[1]: *** [all] Error 2

make: *** [subdirs] Error 1

 

Follow-ups

 

--- Vivi Li                                                  2012-03-06 04:23:37

I build only alsa lib in 2011R1 branch with 2011R1-RC4 toolchain on ubuntu, no

such error happen.

Please refer to attached log: make_alsa-lib_only_log.

 

I also rebuild whole uclinux-dist with default config of BFIN527_EZKIT_V2 and

enabled FDPIC/alsa-lib/alsa-util, still can not see such error.

 

--- Vivi Li                                                  2012-03-09 03:31:39

Close this bug.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

make_alsa-lib_only_log    application/octet-stream    109195    Vivi Li

Outcomes