FAQ: [#6273] MTD NAND driver broken on BF537(2010)

Document created by Aaronwu Employee on Sep 11, 2013
Version 1Show Document
  • View in full screen mode

[#6273] MTD NAND driver broken on BF537

Submitted By: Jay Ku

Open Date

2010-09-24 12:45:47    

Priority:

Medium     Assignee:

steven miao

Status:

Open     Fixed In Release:

N/A

Found In Release:

N/A     Release:

9821

Category:

N/A     Board:

N/A

Processor:

ALL     Silicon Revision:

0.3

Is this bug repeatable?:

Yes     Resolution:

Rejected

Uboot version or rev.:

    Toolchain version or rev.:

4927

App binary format:

N/A     

Summary: MTD NAND driver broken on BF537

Details:

 

MTD platform flash driver appears to be broken.  Lots of invalid bad eraseblocks are reported at boot, nandtest fails, etc.  I'm using custom board with BF537 + NAND04GW3B2DN6E configured identically to BF537 Stamp + ADI CF/IDE/NAND expander board (except I'm using PF14 instead of PF3 for the ready signal from the flash).  See this thread for more info:

 

http://blackfin.uclinux.org/gf/project/uclinux-dist/forum/?_forum_action=MessageReply&message_id=93721&thread_id=42815&action=ForumBrowse&forum_id=39

 

 

Follow-ups

 

--- steven miao                                              2010-10-14 02:55:22

I tested on BF537-stamp with CF/IDE/NAND extender board but cannt repeat this

error. It's OK on ADI's board.

 

root:/>

root:/> flash_eraseall /dev/mtd1

Erasing 128 Kibyte @ 7c00000 -- 100 % complete.

root:/> cat /proc/version

Linux version 2.6.34.7-ADI-2010R1-pre-svn9165 (steven@debiansteven) (gcc

version 4.1.2 (ADI svn)) #164 Sun Sep 26 14:17:08 CST 2010

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes