[#5810] initial sp is given wrong value and INIT_TASK_DATA is not linked into data

Document created by Aaronwu Employee on Sep 5, 2013
Version 1Show Document
  • View in full screen mode

[#5810] initial sp is given wrong value and INIT_TASK_DATA is not linked into data

Submitted By: Barry Song

Open Date

2010-01-05 01:35:58     Close Date

2010-01-06 23:27:56

Priority:

Medium     Assignee:

Barry Song

Status:

Closed     Fixed In Release:

N/A

Found In Release:

2010R1     Release:

Category:

N/A     Board:

N/A

Processor:

ALL     Silicon Revision:

Is this bug repeatable?:

Yes     Resolution:

Fixed

Uboot version or rev.:

    Toolchain version or rev.:

all

App binary format:

N/A     

Summary: initial sp is given wrong value and INIT_TASK_DATA is not linked into data

Details:

 

In head.S,sp is given a wrong value:

         /* Initialize stack pointer */

         sp.l = _init_thread_union;

         sp.h = _init_thread_union;

         fp = sp;

         usp = sp;

sp should be &init_thread_union + THREAD_SIZE.

 

And init_thread_union section name is wrong so it is not linked into data before _edata.

 

The bug exists both in 09r1 and 10r1.

 

Follow-ups

 

--- Barry Song                                               2010-01-06 23:27:54

Ok now. Close it.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes