[#5757] drop USER_SQUASHFS_MKSQUASHFS7Z as squashfs 4.0 does not support 7z anymore

Document created by Aaronwu Employee on Sep 5, 2013
Version 1Show Document
  • View in full screen mode

[#5757] drop USER_SQUASHFS_MKSQUASHFS7Z as squashfs 4.0 does not support 7z anymore

Submitted By: Peter Meerwald

Open Date

2009-12-08 05:56:57    

Priority:

Medium     Assignee:

Sonic Zhang

Status:

Open     Fixed In Release:

N/A

Found In Release:

snaps     Release:

Category:

N/A     Board:

N/A

Processor:

ALL     Silicon Revision:

Is this bug repeatable?:

Yes     Resolution:

Fixed

Uboot version or rev.:

    Toolchain version or rev.:

09r1-10

App binary format:

N/A     

Summary: drop USER_SQUASHFS_MKSQUASHFS7Z as squashfs 4.0 does not support 7z anymore

Details:

 

build fails when enabling USER_SQUASHFS_MKSQUASHFS7Z, 7z is supported for squashfs 2.2, but not 4.0

 

diff --git a/user/Kconfig b/user/Kconfig

index b0fceb5..9c4818f 100644

--- a/user/Kconfig

+++ b/user/Kconfig

@@ -816,12 +816,6 @@ config USER_SQUASHFS_MKSQUASHFS

        help

          Utility to create squashfs filesystems.

 

-config USER_SQUASHFS_MKSQUASHFS7Z

-       bool "mksquashfs7z"

-       select LIB_LIBLZMA

-       help

-         Utility to create squashfs filesystems using p7zip instead of zlib.

-

endmenu

 

Follow-ups

 

--- Sonic Zhang                                              2010-06-29 05:53:29

Fixed in Makefile of squshfs in case user wants to switch back to squashfs 2.2

r2 manually.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes