[#5403] linphone with video support fails to build

Document created by Aaronwu Employee on Sep 4, 2013
Version 1Show Document
  • View in full screen mode

[#5403] linphone with video support fails to build

Submitted By: Peter Meerwald

Open Date

2009-07-28 07:53:40     Close Date

2011-07-07 15:34:47

Priority:

Medium     Assignee:

Nobody

Status:

Closed     Fixed In Release:

N/A

Found In Release:

snaps     Release:

Category:

N/A     Board:

N/A

Processor:

ALL     Silicon Revision:

Is this bug repeatable?:

Yes     Resolution:

Not reproducible

Uboot version or rev.:

    Toolchain version or rev.:

SVN rev. 8599

App binary format:

N/A     

Summary: linphone with video support fails to build

Details:

 

building linphone with video support enabled (USER_LINPHONE_VIDEO) results in:

 

checking for SPEEX... yes

checking for SPEEXDSP... yes

checking gsm/gsm.h usability... no

checking gsm/gsm.h presence... no

checking for gsm/gsm.h... no

checking for FFMPEG... yes

checking for SWSCALE... no

configure: error: Could not find libswscale (from ffmpeg) headers and

library. This is mandatory for video support

configure: error: ../../linphone-3.1.2/mediastreamer2/configure failed

for mediastreamer2

make[3]: *** [build-linphone-3.1.2/Makefile] Error 1

make[3]: Leaving directory

`/home/pmeerw/bf/svn/uclinux-dist/user/linphone'

make[2]: *** [linphone] Error 2

make[2]: Leaving directory `/home/pmeerw/bf/svn/uclinux-dist/user'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/pmeerw/bf/svn/uclinux-dist/user'

make: *** [subdirs] Error 1

 

if I understand correctly, swscale should come from ffmpeg, however

 

uclinux-dist/lib/ffmpeg/Makefile has --enable-swscaler commented out and

the romfs target does not install libswscale.so

 

further, when I add --enable-swscaler to the ffmpeg Makefile, then I get in uclinux-dist/user/linphone/build-linphone-3.1.2/mediastreamer2/config.log:

 

configure:14757: checking for SWSCALE

configure:14765: $PKG_CONFIG --exists --print-errors "libswscale >= 0.7.0 "

Requested 'libswscale >= 0.7.0' but version of libswscale is 0.5.0

configure:14768: $? = 1

configure:14783: $PKG_CONFIG --exists --print-errors "libswscale >= 0.7.0 "

Requested 'libswscale >= 0.7.0' but version of libswscale is 0.5.0

configure:14786: $? = 1

Requested 'libswscale >= 0.7.0' but version of libswscale is 0.5.0

configure:14814: result: no

configure:14827: error: Could not find libswscale (from ffmpeg) headers and library. This is mandatory for video support

 

it seems ffmpeg must be updated to work with linphone 3.1.2 and the ffmpeg Makefile corrected (or the linphone support for video should be dropped)

 

anybody working on this?

suggestions to resolve?

 

Follow-ups

 

--- Yi Li                                                    2009-08-03 03:34:41

Re-assign this bug to Mike. As Peter says, ffmpeg need to be updated to build

linphone-3.1.2.

 

--- Mike Frysinger                                           2010-07-31 02:54:43

i cant reproduce this with trunk:

...

checking for FFMPEG... yes

checking for SWSCALE... yes

checking libavcodec/avcodec.h usability... yes

checking libavcodec/avcodec.h presence... yes

checking for libavcodec/avcodec.h... yes

checking for avcodec_register_all in -lavcodec... yes

checking libswscale/swscale.h usability... yes

checking libswscale/swscale.h presence... yes

checking for libswscale/swscale.h... yes

...

configure:14681: checking for FFMPEG

configure:14689: $PKG_CONFIG --exists --print-errors "libavcodec >=

51.0.0 "

configure:14692: $? = 0

configure:14707: $PKG_CONFIG --exists --print-errors "libavcodec >=

51.0.0 "

configure:14710: $? = 0

configure:14746: result: yes

configure:14757: checking for SWSCALE

configure:14765: $PKG_CONFIG --exists --print-errors "libswscale >=

0.7.0 "

configure:14768: $? = 0

configure:14783: $PKG_CONFIG --exists --print-errors "libswscale >=

0.7.0 "

configure:14786: $? = 0

configure:14822: result: yes

...

 

$ ls staging/usr/lib/pkgconfig/libswscale.pc -l

-rw-r--r-- 1 vapier users 288 Jul 31 02:15

staging/usr/lib/pkgconfig/libswscale.pc

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes