[#4922] unwanted sound comes up after g_audio module is installed on BF548 and BF527

Document created by Aaronwu Employee on Aug 30, 2013
Version 1Show Document
  • View in full screen mode

[#4922] unwanted sound comes up after g_audio module is installed on BF548 and BF527

Submitted By: Vivi Li

Open Date

2009-02-20 05:05:01     Close Date

2009-12-18 03:23:09

Priority:

Medium     Assignee:

Cliff Cai

Status:

Closed     Fixed In Release:

N/A

Found In Release:

2009R1-RC6     Release:

Category:

Drivers     Board:

EZKIT Lite

Processor:

BF548     Silicon Revision:

Is this bug repeatable?:

Yes     Resolution:

Assigned (Not Start)

Uboot version or rev.:

    Toolchain version or rev.:

gcc4.1_2009-01-19

App binary format:

N/A     

Summary: unwanted sound comes up after g_audio module is installed on BF548 and BF527

Details:

 

For gadget audio test on BF548 and BF527, after g_audio module is installed, there will be unwanted sound even nothing is played on PC.

And I can not play audio until module is installed for more than 5 seconds. During this time, error message of "Device or resource busy" will come out.

 

--

(on target board)

root:/> modprobe g_audio

g_audio gadget: Hardware params: access 3, format 2, channels 2, rate 48000

g_audio gadget: audio_buf_size 48000, req_buf_size 200, req_count 256

g_audio gadget: Linux USB Audio Gadget, version: Dec 18, 2008

g_audio gadget: g_audio ready

root:/> g_audio gadget: high speed config #1: Linux USB Audio Gadget

 

(on PC)

test@uclinux63-527-usbdev:~/work/cruise/checkouts/uclinux-dist/testsuites/usbdev> aplay -D plug:hw:1 ../bluetoothalsa/test.wav

ALSA lib pcm_hw.c:1240:(_snd_pcm_hw_open) Invalid value for card

aplay: main:583: audio open error: No such file or directory

 

test@uclinux63-527-usbdev:~/work/cruise/checkouts/uclinux-dist/testsuites/usbdev> aplay -D plug:hw:1 ../bluetoothalsa/test.wav

aplay: main:583: audio open error: Device or resource busy

 

test@uclinux63-527-usbdev:~/work/cruise/checkouts/uclinux-dist/testsuites/usbdev> aplay -D plug:hw:1 ../bluetoothalsa/test.wav

aplay: main:583: audio open error: Device or resource busy

 

test@uclinux63-527-usbdev:~/work/cruise/checkouts/uclinux-dist/testsuites/usbdev> aplay -D plug:hw:1 ../bluetoothalsa/test.wav

aplay: main:583: audio open error: Device or resource busy

 

test@uclinux63-527-usbdev:~/work/cruise/checkouts/uclinux-dist/testsuites/usbdev> aplay -D plug:hw:1 ../bluetoothalsa/test.wav

Playing WAVE '../bluetoothalsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

--

 

Follow-ups

 

--- Vivi Li                                                  2009-08-12 05:27:00

For 09r1 branch, this bug disappear on bf527-ezkit. But still has this problem

on bf548-ezkit.

 

--- Cliff Cai                                                2009-12-18 02:24:19

don't see it on bf527c.AD1980 is out of date.

 

--- Vivi Li                                                  2009-12-18 03:23:09

yes, close it.

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes