[#4717] Very slow ethernet (nothing to do with framebuffer)

Document created by Aaronwu Employee on Aug 30, 2013
Version 1Show Document
  • View in full screen mode

[#4717] Very slow ethernet (nothing to do with framebuffer)

Submitted By: Jiri Beranek

Open Date

2008-12-11 08:37:21     Close Date

2009-02-18 03:10:54

Priority:

Medium     Assignee:

Michael Hennerich

Status:

Closed     Fixed In Release:

N/A

Found In Release:

snaps     Release:

Category:

Networking     Board:

Custom

Processor:

BF537     Silicon Revision:

BF537-0.2

Is this bug repeatable?:

Yes     Resolution:

Fixed

Uboot version or rev.:

    Toolchain version or rev.:

gcc4.1-2008_Dec_12

App binary format:

N/A     

Summary: Very slow ethernet (nothing to do with framebuffer)

Details:

 

I have problem with ethernet functionality, when framebuffer is enabled (custom osd057 driver). Ethernet speed is very slow. I have't this problem with preview versions of uclinux. Any idea? Thanks

 

Follow-ups

 

--- Sonic Zhang                                              2008-12-21 23:45:25

which release? SVN trunk?

 

--- Jiri Beranek                                             2008-12-25 16:34:59

Yes, it is SVN trunk. Sorry for preview mystification, but ethernet is always

slow, not only when framebuffer is enabled. Thanks

 

--- Robin Getz                                               2008-12-26 08:43:22

Jiri:

 

What ethernet chip are you using?

 

-Robin

 

--- Jiri Beranek                                             2008-12-26 18:42:45

I have not external ethernet chip. I am using internal BF537 MAC + LAN83C185

PHY.

 

--- Michael Hennerich                                        2009-01-09 04:19:22

Jiri,

 

Does this issue still exist for you on current svn trunk?

Can you characterize slow?

 

Please submit a

1) complete bugreport

2) kernel startup messages

3) description how you test things

 

-Michael

 

michael@mhenneri-D02:~/devel/svn/uclinux-dist-trunk> make bugreport

rm -rf ./bugreport.tgz ./bugreport

mkdir bugreport

cc -v 2> ./bugreport/host_vers

bfin-uclinux-gcc -v 2> ./bugreport/toolchain_vers

cp .config bugreport/

mkdir bugreport/linux-2.6.x

cp linux-2.6.x/.config bugreport/linux-2.6.x/

mkdir bugreport/config

cp config/.config bugreport/config

tar czf bugreport.tgz bugreport

rm -rf ./bugreport

 

Please attach the file 'bugreport.tgz' to a bug report at

 

  blackfin.uclinux.org/gf/project/uclinux-dist/tracker/?action=TrackerItemAdd&tracker_id=141

 

michael@mhenneri-D02:~/devel/svn/uclinux-dist-trunk>

 

--- Jiri Beranek                                             2009-01-09 18:49:42

Yes issue still exist on current svn trunk.

When connect to blackfin board by telnet 192.168.123.100,

response times between characters is very slow. Ftp dir

command is some time slow too. Connections are not stable.

 

Bugreport & startup messages attached.

 

Big Thanks

 

--- Michael Hennerich                                        2009-01-14 04:25:05

It appears to be a bug in common Linux 2.6.28 code.

Should be fixed on svn trunk now.

 

Please test again and close this bug.

 

-Michael

 

--- Michael Hennerich                                        2009-02-17 10:39:18

Assumed to be fixed and

no further response -

closed

 

-Michael

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

kernelstartup.txt    text/plain    11268    Jiri Beranek

bugreport.tgz    application/x-compressed-tar    18919    Jiri Beranek

Attachments

Outcomes