[#4405] mismatch of rts/gpio direction with UART RTS/CTS

Document created by Aaronwu Employee on Aug 29, 2013
Version 1Show Document
  • View in full screen mode

[#4405] mismatch of rts/gpio direction with UART RTS/CTS

Submitted By: Mike Frysinger

Open Date

2008-09-03 12:54:13     Close Date

2008-09-05 13:06:41

Priority:

Medium     Assignee:

Sonic Zhang

Status:

Closed     Fixed In Release:

N/A

Found In Release:

N/A     Release:

Category:

N/A     Board:

N/A

Processor:

N/A     Silicon Revision:

Is this bug repeatable?:

Yes     Resolution:

Fixed

Uboot version or rev.:

    Toolchain version or rev.:

App binary format:

N/A     

Summary: mismatch of rts/gpio direction with UART RTS/CTS

Details:

 

a user pointed out the issue here:

  blackfin.uclinux.org/gf/project/uclinux-dist/forum/?action=ForumBrowse&_forum_action=MessageReply&message_id=61572

 

some header files set RTS to an input when they should all be outputs

 

Follow-ups

 

--- Sonic Zhang                                              2008-09-03 23:42:37

Fixed.

 

--- Mike Frysinger                                           2008-09-04 01:48:36

could you also check/fix 2007R1 branch

 

--- Mike Frysinger                                           2008-09-05 13:06:41

thanks, should be all set now

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

No Files Were Found

Attachments

    Outcomes