2011-09-14 02:34:57     modprobe - USB Gadget behaves differently with SDRAM size

Document created by Aaronwu Employee on Aug 27, 2013
Version 1Show Document
  • View in full screen mode

2011-09-14 02:34:57     modprobe - USB Gadget behaves differently with SDRAM size

Unmai rr (INDIA)

Message: 103380   

 

Hi,

 

When I put the kernel image and install the USB Gadget on a custom board based on BF526 with 64MB SDRAM,  everything works fine.  When  I put the same image on a board with 32MB SDRAM am getting a response like this(please check the log colored in Red.).  Is it something todo with MUSBcore?  How can I correct it?

 

I have attached the full log file.

 

Jan  1 00:00:01 blackfin user.info kernel: brd: module loaded

Jan  1 00:00:01 blackfin user.info kernel: Freeing unused kernel memory: 6888k freed

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: adding config #3 'source/sink'/002ae3d0

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: adding 'source/sink'/018a27a0 to config 'source/sink'/002ae3d0

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: dual speed source/sink: IN/ep5in, OUT/ep6out

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: cfg 3/002ae3d0 speeds: high full

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget:   interface 0 = source/sink/018a27a0

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: adding config #2 'loopback'/002ae35c

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: adding 'loopback'/018a2800 to config 'loopback'/002ae35c

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: dual speed loopback: IN/ep5in, OUT/ep6out

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget: cfg 2/002ae35c speeds: high full

Jan  1 00:00:53 blackfin user.debug kernel: zero gadget:   interface 0 = loopback/018a2800

Jan  1 00:00:53 blackfin user.info kernel: zero gadget: Gadget Zero, version: Cinco de Mayo 2008

Jan  1 00:56:10 blackfin user.err kernel: musb_g_ep0_irq 676: SetupEnd came in a wrong ep0stage out/status

Jan  1 00:56:10 blackfin user.err kernel: musb_g_ep0_irq 676: SetupEnd came in a wrong ep0stage out/status

Jan  1 00:56:10 blackfin user.err kernel: musb_g_ep0_irq 768: SETUP packet len 0 != 8 ?

Jan  1 00:56:10 blackfin user.err kernel: musb_g_ep0_irq 676: SetupEnd came in a wrong ep0stage out/status

Jan  1 00:56:10 blackfin user.debug kernel: zero gadget: setup complete --> 0, 64/98

Jan  1 00:56:10 blackfin user.info kernel: zero gadget: high speed config #3: source/sink

Jan  1 00:56:10 blackfin user.debug kernel: zero gadget: source/sink enabled

Jan  1 01:30:32 blackfin user.debug kernel: zero gadget: suspend

Jan  1 01:30:32 blackfin user.debug kernel: zero gadget: zero_suspend

Jan  1 01:30:32 blackfin user.debug kernel: zero gadget: reset config

Jan  1 01:31:32 blackfin user.debug kernel: zero gadget: unbind function 'source/sink'/018a27a0

Jan  1 01:31:32 blackfin user.debug kernel: zero gadget: unbind function 'loopback'/018a2800

 

 

 

-Unmai

QuoteReplyEditDelete

 

 

2011-09-14 04:06:35     Re: modprobe - USB Gadget behaves differently with SDRAM size

Sonic Zhang (CHINA)

Message: 103383   

 

please put your modprobe command line here.

QuoteReplyEditDelete

 

 

2011-09-14 06:06:31     Re: modprobe - USB Gadget behaves differently with SDRAM size

Unmai rr (INDIA)

Message: 103384   

 

it was

 

root@Modprobe g_zero

 

 

 

-Unmai.

QuoteReplyEditDelete

 

 

2011-09-14 06:15:41     Re: modprobe - USB Gadget behaves differently with SDRAM size

Sonic Zhang (CHINA)

Message: 103385   

 

Is the board with 32MB SDRAM exactly the same as your customer bf526 board with 64MB?

QuoteReplyEditDelete

 

 

2011-09-26 06:25:22     Re: modprobe - USB Gadget behaves differently with SDRAM size

Unmai rr (INDIA)

Message: 103542   

 

Yes, I just replaced the 32MB SDRAM with 64MB SDRAM to run the VDSP driver and on the same board I tested the USB on linux platform and got the above result.

QuoteReplyEditDelete

 

 

2011-09-26 23:31:00     Re: modprobe - USB Gadget behaves differently with SDRAM size

Bob Liu (CHINA)

Message: 103550   

 

Could you please try with another USB wire?

Attachments

    Outcomes