2011-08-09 04:57:59     [Samba 3.5.11] Error running "configure"

Document created by Aaronwu Employee on Aug 27, 2013
Version 1Show Document
  • View in full screen mode

2011-08-09 04:57:59     [Samba 3.5.11] Error running "configure"

Gilles Ganault (FRANCE)

Message: 102860   

Hello

 

As the Samba in the uClinux-dist 2010 is pretty old (3.0.25a), I wanted to cross-compile the latest stable available from the Samba web site (3.5.11).

 

Although "autogen.sh" seems to run OK, "configure" fails:

 

[code]

ubuntu:/usr/src/samba-3.5.11/source3# CC=bfin-linux-uclibc-gcc CFLAGS="-I/usr/src/uClinux-dist-2010R1-RC5/linux-2.6.x/include" ./autogen.sh --build=i686-pc-linux --host=bfin-linux-uclibc

 

./autogen.sh: running script/mkversion.sh

./script/mkversion.sh: 'include/version.h' created for Samba("3.5.11")

./autogen.sh: running autoheader -Im4 -I../m4 -I../lib/replace -I../source4

samba4.m4:6: warning: file `../m4/check_python.m4' included several times

samba4.m4:83: warning: file `../lib/tdb/libtdb.m4' included several times

../source4/build/m4/public.m4:70: SMB_EXT_LIB_FROM_PKGCONFIG is expanded from...

samba4.m4:83: the top level

../lib/tevent/samba.m4:3: warning: file `../lib/tevent/libtevent.m4' included several times

../lib/tevent/samba.m4:3: the top level

./autogen.sh: running autoconf -Im4 -I../m4 -I../lib/replace -I../source4

samba4.m4:6: warning: file `../m4/check_python.m4' included several times

samba4.m4:83: warning: file `../lib/tdb/libtdb.m4' included several times

../source4/build/m4/public.m4:70: SMB_EXT_LIB_FROM_PKGCONFIG is expanded from...

samba4.m4:83: the top level

../lib/tevent/samba.m4:3: warning: file `../lib/tevent/libtevent.m4' included several times

../lib/tevent/samba.m4:3: the top level

Now run ./configure (or ./configure.developer) and then make.

 

ubuntu:/usr/src/samba-3.5.11/source3# CC=bfin-linux-uclibc-gcc CFLAGS="-I/usr/src/uClinux-dist-2010R1-RC5/linux-2.6.x/include" ./configure --build=i686-pc-linux --host=bfin-linux-uclibc

 

...

checking that the C compiler understands negative enum values... configure: error: in `/usr/src/samba-3.5.11/source3':

configure: error: cannot run test program while cross compiling

 

See `config.log' for more details

 

[/code]

 

Has someone successfuly cross-compiled Samba?

 

Thank you.

Attachments

    Outcomes