2011-06-18 06:29:00     Need help on usb audio gadget

Document created by Aaronwu Employee on Aug 27, 2013
Version 1Show Document
  • View in full screen mode

2011-06-18 06:29:00     Need help on usb audio gadget

Power Pan (CHINA)

Message: 101431   

 

Hi,

 

just want help on using g_audio.ko. while insmod g_audio.ko, below information was shown

 

g_audio gadget: Hardware params: access 3, format 2, channels 2, rate 48000

 

g_audio gadget: audio_buf_size 48000, req_buf_size 200, req_count 256

 

g_audio gadget: Linux USB Audio Gadget, version: Dec 18, 2008

 

g_audio gadget: g_audio ready

 

musb_hdrc musb_hdrc: MUSB HDRC host driver

 

musb_hdrc musb_hdrc: new USB bus registered, assigned bus number 3

 

hub 3-0:1.0: USB hub found

 

hub 3-0:1.0: 1 port detected

 

musb g_audio gadget disconnected.

 

g_audio gadget: high speed config #1: Linux USB Audio Gadget

 

 

 

and PC site could find the USB audio but cannot start it (code 10), how I could debug the code to see what's the problem?

 

thanks a lot.

QuoteReplyEditDelete

 

 

2011-06-30 22:00:25     Re: Need help on usb audio gadget

Power Pan (CHINA)

Message: 101945   

 

难道没有人知道这个问题吗?

QuoteReplyEditDelete

 

 

2011-06-30 23:05:10     Re: Need help on usb audio gadget

Aaron Wu (CHINA)

Message: 101947   

 

You need to provide information for what kind of Blackfin CPU you are using, the hardware version, software version, and other information for reproducing your issue before we can investigate.

QuoteReplyEditDelete

 

 

2011-07-05 06:01:55     Re: Need help on usb audio gadget

Aaron Wu (CHINA)

Message: 102126   

 

With a bf527 board, sm2602 add-on card, 2010R1 release, ubuntu 10.04, verified it works fine. like this document says:   docs.blackfin.uclinux.org/doku.php?id=linux-kernel:usb-gadget:audio

Attachments

    Outcomes