2011-06-30 10:03:20     UBIFS: recovery needed / Structure needs cleaning

Document created by Aaronwu Employee on Aug 27, 2013
Version 1Show Document
  • View in full screen mode

2011-06-30 10:03:20     UBIFS: recovery needed / Structure needs cleaning

Reggy Perrin (UNITED STATES)

Message: 101931   

 

Hi folks,

 

We've seen a UBIFS corruption occur.  The boot log is:

[ 4.656000] UBI: attaching mtd5 to ubi1

[ 4.660000] UBI: physical eraseblock size: 131072 bytes (128 KiB)

[ 4.664000] UBI: logical eraseblock size: 129024 bytes

[ 4.668000] UBI: smallest flash I/O unit: 2048

[ 4.672000] UBI: sub-page size: 512

[ 4.680000] UBI: VID header offset: 512 (aligned 512)

[ 4.684000] UBI: data offset: 2048

[ 5.060000] UBI: attached mtd5 to ubi1

[ 5.064000] UBI: MTD device name: "home"

[ 5.068000] UBI: MTD device size: 93 MiB

[ 5.072000] UBI: number of good PEBs: 750

[ 5.076000] UBI: number of bad PEBs: 0

[ 5.080000] UBI: max. allowed volumes: 128

[ 5.084000] UBI: wear-leveling threshold: 4096

[ 5.088000] UBI: number of internal volumes: 1

[ 5.092000] UBI: number of user volumes: 1

[ 5.096000] UBI: available PEBs: 0

[ 5.100000] UBI: total number of reserved PEBs: 750

[ 5.104000] UBI: number of PEBs reserved for bad PEB handling: 7

[ 5.108000] UBI: max/mean erase counter: 3/1

[ 5.112000] UBI: image sequence number: 458433007

[ 5.132000] UBI: background thread "ubi_bgt1d" started, PID 361

UBI device number 1, total 750 LEBs (96768000 bytes, 92.3 MiB), available 0 LEBs (0 bytes), LEB size 129024 bytes (126.0 KiB)

[ 5.228000] UBIFS: recovery needed

[ 5.320000] UBIFS error (pid 363): ubifs_scanned_corruption: corruption at LEB 172:45056

[ 5.348000] UBIFS error (pid 363): ubifs_recover_leb: LEB 172 scanning failed

mount: mounting ubi1:home on /home failed: Structure needs cleaning

 

What might cause it?  We have never seen an error like this before.

 

Is there any way to repair?

 

Thanks,

RP

QuoteReplyEditDelete

 

 

2011-07-01 05:33:21     Re: UBIFS: recovery needed / Structure needs cleaning

Aaron Wu (CHINA)

Message: 101975   

 

As the log says"recovery needed", I tink you may get more help from   www.linux-mtd.infradead.org/doc/ubi.html. I test the UBI mount on a BF548 board looks like it's working well.

QuoteReplyEditDelete

Attachments

    Outcomes