2011-06-27 22:28:25     problems of U-BOOT compiling on BF518 target

Document created by Aaronwu Employee on Aug 27, 2013
Version 1Show Document
  • View in full screen mode

2011-06-27 22:28:25     problems of U-BOOT compiling on BF518 target

lin cheng (CHINA)

Message: 101734   

 

According to your slides,

 

§How to compile

Ømake <board>    (make bf537-stamp)

Ømake

 

i typed following commang ,

 

make bf518f-ezbrd

 

make ,

 

the term shows:

 

[root@localhost trunk]# make bf518f-ezbrd

Configuring for bf518-ezbrd board...

make

make[1]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk'

Generating include/autoconf.mk

cc1: error: missing argument to "-mcpu="

Generating include/autoconf.mk.dep

cc1: error: missing argument to "-mcpu="

make[1]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk'

make[1]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk'

for dir in tools examples/standalone examples/api arch/blackfin/cpu arch/blackfin/lib/ ; do \

                        make -C $dir _depend ; done

make[2]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/tools'

make[2]: Nothing to be done for `_depend'.

make[2]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/tools'

make[2]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/examples/standalone'

make[2]: Nothing to be done for `_depend'.

make[2]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/examples/standalone'

make[2]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/examples/api'

make[2]: Nothing to be done for `_depend'.

make[2]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/examples/api'

make[2]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/arch/blackfin/cpu'

make[2]: Nothing to be done for `_depend'.

make[2]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/arch/blackfin/cpu'

make[2]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/arch/blackfin/lib'

make[2]: Nothing to be done for `_depend'.

make[2]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/arch/blackfin/lib'

make -C tools all

make[2]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/tools'

make[2]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/tools'

make -C examples/standalone all

make[2]: Entering directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/examples/standalone'

bfin-uclinux-gcc  -g  -Os   -ffixed-P3 -fomit-frame-pointer -mno-fdpic -ffunction-sections -fdata-sections -mcpu= -D__KERNEL__ -I/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/include -fno-builtin -ffreestanding -nostdinc -isystem /usr/local/dsp/blackfin/uClinux.2010R1-RC4/bfin-uclinux/bin/../lib/gcc/bfin-uclinux/4.3.5/include -pipe  -DCONFIG_BLACKFIN -DBFIN_CPU='""' -Wall -Wstrict-prototypes    \

                -o hello_world.o hello_world.c -c

Assembler messages:

Fatal error: -mcpu= is not valid

cc1: error: missing argument to "-mcpu="

make[2]: *** [hello_world.o] Error 1

make[2]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk/examples/standalone'

make[1]: *** [examples/standalone] Error 2

make[1]: Leaving directory `/home/cheng/project/company/emb-gate/platform-BF518/source/Uboot/uboot/trunk'

make: *** [bf518f-ezbrd] Error 2

 

how to resove it?

TranslateQuoteReplyEditDelete

 

 

2011-06-27 22:46:50     Re: problems of U-BOOT compiling on BF518 target

Aaron Wu (CHINA)

Message: 101735   

 

Suggest you to start with a clean 2010R1 U-boot package downloaded from our website, or at least do a make clean for your own one, also make sure 2010R1 toolchain is properly installed.  I just try what you did and see no problem in my environment.

Attachments

    Outcomes