2011-06-04 17:21:03     Trouble compiliing

Document created by Aaronwu Employee on Aug 27, 2013
Version 1Show Document
  • View in full screen mode

2011-06-04 17:21:03     Trouble compiliing

Josh Kennington (UNITED STATES)

Message: 101000   

 

When I run make, It chugs and does its thing for a while.  Eventually I get the following:

 

 

 

bfin-uclinux-gcc  -o boa alias.o boa.o buffer.o cgi.o cgi_header.o config.o escape.o get.o hash.o ip.o log.o mmap_cache.o pipe.o queue.o range.o read.o request.o response.o signals.o util.o sublog.o select.o timestamp.o -Wl,-elf2flt    -mcpu=bf537-0.2 -g

bfin-uclinux-gcc  -o boa_indexer index_dir.o escape.o -Wl,-elf2flt    -mcpu=bf537-0.2 -g

make[6]: Leaving directory `/home/benicio/blackfin-linux-dist/user/boa/build-boa-0.94.14rc21/src'

make[5]: Leaving directory `/home/benicio/blackfin-linux-dist/user/boa/build-boa-0.94.14rc21'

make[4]: Leaving directory `/home/benicio/blackfin-linux-dist/user/boa'

make -C build-boa-0.94.14rc21 install DESTDIR=/home/benicio/blackfin-linux-dist/staging

make[4]: Entering directory `/home/benicio/blackfin-linux-dist/user/boa/build-boa-0.94.14rc21'

Please read the documentation then install manually.

make[4]: Leaving directory `/home/benicio/blackfin-linux-dist/user/boa/build-boa-0.94.14rc21'

make post-build

make[4]: Entering directory `/home/benicio/blackfin-linux-dist/user/boa'

make[4]: Nothing to be done for `post-build'.

make[4]: Leaving directory `/home/benicio/blackfin-linux-dist/user/boa'

/home/benicio/blackfin-linux-dist/tools/cross-fix-root

make[3]: Leaving directory `/home/benicio/blackfin-linux-dist/user/boa'

make[2]: Leaving directory `/home/benicio/blackfin-linux-dist/user'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/benicio/blackfin-linux-dist/user'

make: *** [subdirs] Error 1

 

 

So I get two errors.  I don't understand why.  I am just trying to do a simple build with the arbitrary waveform generator on a SUSE box.  I can't find the uImage file anywhere, so I am fairly certain its not completing the build.  I can find a vmlinux.img, but I don't think that is what I want?  I am using a bf537-stamp.  It seems like there shoud be a simple solution to this, since I haven't really even modified anything yet.  Help?

QuoteReplyEditDelete

 

 

2011-06-04 23:40:33     Re: Trouble compiliing

Mike Frysinger (UNITED STATES)

Message: 101001   

 

that doesnt show the actual error.  you need to read the log history, or run `make single` so that the first error aborts right away.

QuoteReplyEditDelete

 

 

2011-06-05 12:30:48     Re: Trouble compiliing

Josh Kennington (UNITED STATES)

Message: 101005   

 

Okay, so looking back it looks like this is the error it throws out

 

Makefile: 27: *** Mixed implicit and normal rules. Stop.

 

 

 

It does this right after entering the apps directory by the look of it.

QuoteReplyEditDelete

 

 

2011-06-05 12:34:58     Re: Trouble compiliing

Josh Kennington (UNITED STATES)

Message: 101006   

 

It looks like this was in the frequently asked questions, so I'll spare you the trouble of responding.  Thanks!

Attachments

    Outcomes