2011-05-04 04:01:32     rndis problems with vista and win7

Document created by Aaronwu Employee on Aug 26, 2013
Version 1Show Document
  • View in full screen mode

2011-05-04 04:01:32     rndis problems with vista and win7

Mattias K (SWEDEN)

Message: 100412   

 

Hi,

 

It seems like using the ethernet over usb slows down some applications on my host. I have BF537 and a net2272 usb controller and are using 2010R1-RC5 (dist) and 2010-RC4 (toolchain). The drivers that I use on the blackfin side is the default rndis driver supplied with the dist.

 

On the host side I use the drivers that are supplied my microsoft.

 

When I connect my device to a windows host running XP and starts MS outlook everything works well, (see the attached document for the debug messages from the rndis driver). However when I do the same thing with a win7 host the startup of MS outlook has a long delay (very long if I use the usb at full speed comapared to high speed). The only difference I see in the debug log is the message gen_ndis_query_resp: OID_GEN_RCV_NO_BUFFER . The answer is always 0 but I don't see why this is happening.

 

I have attached the log

 

Does anybody know anything about this? This is extremely important to us, if anybody has some contact information to people who can help us, pls let me know.

 

regards,

 

Mattias

 

 

 

 

rndis_messages.ods

QuoteReplyEditDelete

 

 

2011-05-04 10:31:25     Re: rndis problems with vista and win7

Mike Frysinger (UNITED STATES)

Message: 100420   

 

sorry, but we cant really support non-ADI USB controllers.  the driver you're using comes from PLX (who makes the usb part you're using), so you'll probably want to file a support request with them ...

QuoteReplyEditDelete

 

 

2011-05-04 15:57:48     Re: rndis problems with vista and win7

Mattias K (SWEDEN)

Message: 100426   

 

thanks, I'll try that.

 

/Mattias

Attachments

Outcomes