2011-04-21 14:29:00     Can someone using 2010R1 on BF537 run this SocketCAN test for me?

Document created by Aaronwu Employee on Aug 26, 2013
Version 1Show Document
  • View in full screen mode

2011-04-21 14:29:00     Can someone using 2010R1 on BF537 run this SocketCAN test for me?

Jay Ku (UNITED STATES)

Message: 100089   

 

I'm seeing a problem with the SocketCAN driver that I've described at   blackfin.uclinux.org/gf/forumthread/44654 and https://blackfin.uclinux.org/gf/tracker/6501.  I see the problem on my BF537 stamp board and on a custom board.  My bug report was rejected, and the examiner never replied to my follow-up questions.

 

If someone could run 'candump can0 -e 0xffffffff' and let me know if they see any errors, I'd appreciate it.

 

Thanks

QuoteReplyEditDelete

 

 

2011-04-21 23:08:16     Re: Can someone using 2010R1 on BF537 run this SocketCAN test for me?

Sonic Zhang (CHINA)

Message: 100111   

 

Have you tried on 2 bf537-stamp board? Maybe you need to check your cable.

QuoteReplyEditDelete

 

 

2011-04-21 23:43:18     Re: Can someone using 2010R1 on BF537 run this SocketCAN test for me?

Jay Ku (UNITED STATES)

Message: 100112   

 

I only have one stamp board, but I've tried it with a Kvaser CAN adapter, which is pretty much the standard in CAN.

 

Can someone from ADI try the image I attached to my follow-up on the tracker?  Should only take a few minutes.

QuoteReplyEditDelete

 

 

2011-04-22 00:03:23     Re: Can someone using 2010R1 on BF537 run this SocketCAN test for me?

Aaron Wu (CHINA)

Message: 100113   

 

Jay,

 

We don't have your Kvaser CAN adapter, for the bug 6501 we made some effort on it and the test result turns out to be fine on two blackfin board, we did no special change.  Maybe you can build the same version as our side, 2.6.34.7-ADI-2010R1-svn9517 version and have a try? if have a problem then the hardware matters.

QuoteReplyEditDelete

 

 

2011-04-22 04:46:57     Re: Can someone using 2010R1 on BF537 run this SocketCAN test for me?

steven miao (CHINA)

Message: 100123   

 

Jay,

 

The test result with your uImage post at https://blackfin.uclinux.org/gf/project/uclinux-dist/tracker/?action=TrackerItemEdit&tracker_id=141&tracker_item_id=6501

 

There's no error message, candump just wait for incoming can packet.

QuoteReplyEditDelete

 

 

2011-04-22 10:58:07     Re: Can someone using 2010R1 on BF537 run this SocketCAN test for me?

Jay Ku (UNITED STATES)

Message: 100131   

 

Steven,

 

You just let the thing run with no data on the bus and didn't see any errors?  I don't see any errors if I just let it sit there either, but with every valid packet received, I'm also having an error packet generated.  None of the other nodes on my bus are seeing this error (not just the Kvaser, but some Microchip PIC-based nodes).

 

Can you run my image and send some packets from another board?

 

Thanks,

 

Jay

Attachments

    Outcomes