2011-03-25 15:14:25     Relocation error with own binary

Document created by Aaronwu Employee on Aug 26, 2013
Version 1Show Document
  • View in full screen mode

2011-03-25 15:14:25     Relocation error with own binary

Glenn Hart (UNITED STATES)

Message: 99263   

 

I am trying to get my custom binary to work and am having difficulty.  Whenever I execute the application I get:

 

BINFMT_FLAT: Unknown relocation type 5

 

I have delete everything from the application where is only include stdio.h and has a printf as the only statement in main.  My Makefile is the same as the 'version' application.  Looking at the compiling output, they appear to compile and link identically.  version works fine when execute, but my does not.  Anyone have any ideas on what could be wrong.

 

Thanks,

 

Glenn

QuoteReplyEditDelete

 

 

2011-03-25 15:21:08     Re: Relocation error with own binary

Mike Frysinger (UNITED STATES)

Message: 99265   

 

you must be using the same version of toolchain/kernel/etc... like the documentation states.

 

please remove all that you've installed, download the 2010R1 release for everything, and then install/build/boot that.

QuoteReplyEditDelete

 

 

2011-03-25 15:46:04     Re: Relocation error with own binary

Glenn Hart (UNITED STATES)

Message: 99268   

 

I would rather not remove everything and install the latest version.  I have working what I need and would rather not need to redo everything.  If the problem is with the versions of the tool chain/kernel, why does the version application (and all the others) work when they are compiled?

 

Glenn

QuoteReplyEditDelete

 

 

2011-03-25 15:49:42     Re: Relocation error with own binary

Mike Frysinger (UNITED STATES)

Message: 99269   

 

i cant guess as to why your env is broken.  if you're seeing that error, then, like the FAQ already says, you're wrongly mixing toolchain and kernel versions.  dont do that.

 

  docs.blackfin.uclinux.org/doku.php?id=faq

(I get "BINFMT_FLAT: bad flat file version 0x5")

QuoteReplyEditDelete

 

 

2011-04-11 15:24:41     Re: Relocation error with own binary

Glenn Hart (UNITED STATES)

Message: 99763   

 

I figured out my problem.  I am running linux in Virtual Box with the compilier.  The directory with my app is a Virtual Box shared folder to my computer.  When compiling, the resulting size of the object file and the binary file are different and result in my error.

Attachments

    Outcomes