2011-03-24 05:03:50     Can't open SPORT1 on BF518F Board

Document created by Aaronwu Employee on Aug 26, 2013
Version 1Show Document
  • View in full screen mode

2011-03-24 05:03:50     Can't open SPORT1 on BF518F Board

Sohan Mikkilineni (UNITED STATES)

Message: 99212   

 

Hi all,

 

I believe I managed to get SPORT0 to respond, but whenever I try to write to SPORT1 (with something like 'echo 123 > /dev/sport1), the BF518F board just resets without returning anything. I'm very new to embedded Linux so I might have done something wrong... any ideas? In my config, I disabled UART and MMC to avoid conflicts with SPORT0 (and enabled the SPORT driver).

 

Thanks!

QuoteReplyEditDelete

 

 

2011-03-24 09:56:18     Re: Can't open SPORT1 on BF518F Board

Mike Frysinger (UNITED STATES)

Message: 99216   

 

you need to configure the sport parameters before trying to read/write it otherwise the driver will wait indefinitely

QuoteReplyEditDelete

 

 

2011-03-24 11:40:01     Re: Can't open SPORT1 on BF518F Board

Sohan Mikkilineni (UNITED STATES)

Message: 99218   

 

Hi Mike,

 

Thanks for the reply! I'm not well versed, so I'm sorry if this is a really basic question... but do you configure those parameters in the bfin_sport code?

QuoteReplyEditDelete

 

 

2011-03-24 13:26:55     Re: Can't open SPORT1 on BF518F Board

Mike Frysinger (UNITED STATES)

Message: 99219   

 

please review the documentation:

  docs.blackfin.uclinux.org/doku.php?id=linux-kernel:drivers:bfin_sport

Attachments

    Outcomes