2010-11-20 02:55:04     video problem

Document created by Aaronwu Employee on Aug 23, 2013
Version 1Show Document
  • View in full screen mode

2010-11-20 02:55:04     video problem

haiqing cao (CHINA)

Message: 96024   

 

After I build the ffmpeg, I want to test my camera driver. I used the order ffmpeg -f video4linux -r 10.0 -s 720×288 -i /dev/video0 -qscale 6 -f mjpeg foo. but  it is stop after the follows.

 

 

root:/dev> ffmpeg -f video4linux -r 10.0 -s 720x288 -i /dev/video0 -qscale 6 -f

mjpeg foo

FFmpeg version UNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.

  configuration: --prefix=/usr --source-path=/opt/uClinux-dist/lib/ffmpeg/build/../ffmpeg-svn-11114 --target-os=Linux --cpu=bfin --arch=bfin --extra-ldflags=    -mcpu=bf561-0.3 --enable-static --enable-shared --enable-gpl --enable-pp --disable-strip --cross-prefix=bfin-linux-uclibc-

  libavutil version: 49.5.0

  libavcodec version: 51.48.0

  libavformat version: 52.1.0

  built on Nov 19 2010 21:22:55, gcc: 4.1.2 (ADI svn)

I don't know how to solute this.

QuoteReplyEditDelete

 

 

2010-11-21 23:01:41     Re: video problem

Sonic Zhang (CHINA)

Message: 96072   

 

run strace ffmpeg or hoot a gdbserver.

QuoteReplyEditDelete

 

 

2010-11-22 02:29:23     Re: video problem

haiqing cao (CHINA)

Message: 96073   

 

thank you for your help. but I don't know how to do this . can you give me ye detail? thank you  for your help again.

QuoteReplyEditDelete

 

 

2010-11-22 02:35:41     Re: video problem

Aaron Wu (CHINA)

Message: 96074   

 

For strace:   docs.blackfin.uclinux.org/doku.php?id=uclinux-dist:strace

 

For gdbserver:   docs.blackfin.uclinux.org/doku.php?id=debuggers&s[]=gdbserver

Attachments

    Outcomes