2010-09-21 09:39:55     Error: Undefined reference to _ts_*

Document created by Aaronwu Employee on Aug 23, 2013
Version 1Show Document
  • View in full screen mode

2010-09-21 09:39:55     Error: Undefined reference to _ts_*

Sivakumar S (INDIA)

Message: 93701   

 

Hi All,

 

I am trying to build Qt 4.6.2 for my blackfin 527 board. It giving me an "undefined reference to _ts_*" error at the end of compilation. Before compiling Qt, i have already compiled tslib 1.0 properly. I did a static compilation of the libraries using the following options.

 

./configure –host=bfin-linux-uclibc CC=/home/Jagadish/linux/opt/uClinux/bfin-linux-uclibc/bin/bfin-linux-uclibc-gcc --disable-h2200-linear --disable-ucb1x00 --disable-corgi --disable-collie --disable-h3600 --disable-mk712 --disable-arctic2 --prefix=$TS_INSTALL CFLAGS='-DUSE_INPUT_API'

 

I am using FDPIC tool chain for compilation. After installing the tslib, i am able to view all required files in my /usr/local directory. But still i am getting this error. Please help me with this regard...

 

A similar issue was posted in the below link. I didnt find a convincing answer of the same. So posting it again...

 

  blackfin.uclinux.org/gf/forumthread/32938

 

Regards,

 

Siva

QuoteReplyEditDelete

 

 

2010-09-21 13:51:59     Re: Error: Undefined reference to _ts_*

Mike Frysinger (UNITED STATES)

Message: 93705   

 

you need to post actual commands you're running and their actual output

 

missing references to _ts_* most likely means you arent linking the libts library correctly

QuoteReplyEditDelete

Attachments

    Outcomes