2010-07-19 04:59:29     uClinux release 2009 1.1 -RC4

Document created by Aaronwu Employee on Aug 22, 2013
Version 1Show Document
  • View in full screen mode

2010-07-19 04:59:29     uClinux release 2009 1.1 -RC4

Stephane DEBUSNE (FRANCE)

Message: 91434   

 

Hi all,

 

 

 

i've got a board with an "old" u-boot u-boot-1.1.6-2008R1.5 and an "old" uClinux version uClinux-dist-2008R1.5-RC3 that is working fine.

 

 

 

i'd like to update the uCLinux version to the last release : 2009R1.1-RC4 but i'm running into troubles... I do not know why but the kernel does not start.

 

 

 

Does the u-boot version may be the reason for this or may this work with my u-boot version ?

 

 

 

thanks for any answer

 

 

 

regards

 

 

 

Stephane

QuoteReplyEditDelete

 

 

2010-07-19 05:07:44     Re: uClinux release 2009 1.1 -RC4

Sonic Zhang (CHINA)

Message: 91436   

 

Update grade your uboot release first.

QuoteReplyEditDelete

 

 

2010-07-19 05:18:02     Re: uClinux release 2009 1.1 -RC4

Stephane DEBUSNE (FRANCE)

Message: 91437   

 

Thanks for the answer.

 

Is the u-boot version really involved in the "crash" of the kernel ?

 

More over, in my previous kernel settings, there was some fields for the sdram size. It seems this configuration has been removed in the 2009R1.1-RC4 release... right ?

 

About u-boot... i tried an update but here again, i've got some troubles. that's why i asked. i do prefer debbuging linux kernel instead of u-boot... :

 

ubbot crash :

 

Ack! Something bad happened to the Blackfin!

 

SEQUENCER STATUS:

SEQSTAT: 0000c000  IPEND: 8030  SYSCFG: 0032

  HWERRCAUSE: 0x3: external memory addressing error

  EXCAUSE   : 0x0: custom exception

QuoteReplyEditDelete

 

 

2010-07-19 06:07:18     Re: uClinux release 2009 1.1 -RC4

Stephane DEBUSNE (FRANCE)

Message: 91441   

 

Ok, i add a running version of u-boot-2008.10-2009R1.1-rc1 (with a minor change in irq_init() in order to work ?)

 

and it does not change anything for my Kernel Startup...

 

I don't know where it crash because i do not have any message on my console after starting kernel at XXXXXXX

 

How may i debug that ?

 

 

 

thanks

 

regards

 

 

 

Stephane

QuoteReplyEditDelete

 

 

2010-07-19 06:40:06     Re: uClinux release 2009 1.1 -RC4

Michael Hennerich (GERMANY)

Message: 91442    > I don't know where it crash because i do not have any message on my

> console after starting kernel at XXXXXXX

 

Your kernel might not be crashing - it's more likely it doesn't print anything due to your cmdline.

Check your kernel command line - you need proper console= and earlyprintk= init.

QuoteReplyEditDelete

 

 

2010-07-19 07:00:56     Re: uClinux release 2009 1.1 -RC4

Stephane DEBUSNE (FRANCE)

Message: 91443   

 

The cmdline is ok, and it works with an old kernel.

 

here is my bootargs :

 

bootargs=root=/dev/mtdblock1 rw rootfstype=jffs2 earlyprintk=serial,uart0,115200

console=ttyBF0,115200

 

 

 

I think it crash right after the entry point, maybe the same kind of thing that made my u-boot "new version" crashing when enabling local irqs due to an unknown pending irq...

QuoteReplyEditDelete

 

 

2010-07-19 14:05:48     Re: uClinux release 2009 1.1 -RC4

Mike Frysinger (UNITED STATES)

Message: 91459   

 

review the post mortem documentation:

  docs.blackfin.uclinux.org/doku.php?id=linux-kernel:debug:post_mortem

QuoteReplyEditDelete

 

 

2010-07-20 15:24:45     Re: uClinux release 2009 1.1 -RC4

Robin Getz (UNITED STATES)

Message: 91511   

 

Stephane:

 

The ABI between the kernel and U-Boot is not fixed - and changes between versions - just because something works with an old version - does not mean it will work with new versions.

 

Upgrade.

 

-Robin

Attachments

    Outcomes