2010-06-28 06:32:42     [2009R1.1-RC4] "stl/_config.h: No such file or directory"

Document created by Aaronwu Employee on Aug 22, 2013
Version 1Show Document
  • View in full screen mode

2010-06-28 06:32:42     [2009R1.1-RC4] "stl/_config.h: No such file or directory"

Gilles Ganault (FRANCE)

Message: 90674   

Hello

 

When trying to compile 2009R1.1-RC4 on an x86 running Ubuntu 10.04 LTS, I get apparently the same error mentioned in this thread.

 

=================

make[4]: Entering directory `/usr/src/uClinux-dist/lib/STLport'

 

make -C build/lib -f uclinux-dist.mak install ARCH=a

 

make[5]: Entering directory `/usr/src/uClinux-dist/lib/STLport/build/lib'

 

bfin-uclinux-g++ -pipe -Wall -g -O2  -mcpu=bf518-0.0 -pthread -fexceptions

 

-fident  -fPIC -O2 -fuse-cxa-atexit  -D_STLP_REAL_LOCALE_IMPLEMENTED

 

-D_GNU_SOURCE  -I/usr/src/uClinux-dist/include/STLport

 

-I/usr/src/uClinux-dist/include  -c -o obj/gcc/shared/dll_main.o

 

../../src/dll_main.cpp

 

 

In file included from ../../src/dll_main.cpp:29:

 

../../src/stlport_prefix.h:20:25: error: stl/_config.h: No such file or directory

=================

 

Does someone know what to do? Am I missing some extra library/package?

 

 

Thank you.

QuoteReplyEditDelete

 

 

2010-06-28 06:52:05     Re: [2009R1.1-RC4] "stl/_config.h: No such file or directory"

Gilles Ganault (FRANCE)

Message: 90676   

 

FWIW, installing the "libstlport" package and its "-dev" counterpart doesn't solve the issue:

 

# apt-get install libstlport5.2 libstlport5.2-dev

 

# dpkg -l | grep -i stlport

 

libstlport5.2                   5.2.1-5

 

libstlport5.2-dev               5.2.1-5

 

# make single

 

[...]

 

[ -z "libssl libg zlib libjpeg STLport expat lzo sqlite" ] || make -j1 STLport expat libg libjpeg libssl lzo sqlite zlib || exit $?

 

make[3]: Entering directory `/usr/src/uClinux-dist/lib'

 

[ ! -d "STLport" ] || ( touch STLport/.sgbuilt_lib && make -C STLport ) || exit $?

 

make[4]: Entering directory `/usr/src/uClinux-dist/lib/STLport'

 

make -C build/lib -f uclinux-dist.mak install ARCH=a

 

make[5]: Entering directory `/usr/src/uClinux-dist/lib/STLport/build/lib'

 

bfin-uclinux-g++ -pipe -Wall -g -O2  -mcpu=bf518-0.0 -pthread -fexceptions -fident  -fPIC -O2 -fuse-cxa-atexit  -D_STLP_REAL_LOCALE_IMPLEMENTED -D_GNU_SOURCE  -I/usr/src/uClinux-dist/include/STLport -I/usr/src/uClinux-dist/include  -c -o obj/gcc/shared/dll_main.o ../../src/dll_main.cpp

 

In file included from ../../src/dll_main.cpp:29:

 

../../src/stlport_prefix.h:20:25: error: stl/_config.h: No such file or directory

 

Thank you.

QuoteReplyEditDelete

 

 

2010-06-28 13:09:58     Re: [2009R1.1-RC4] "stl/_config.h: No such file or directory"

Mike Frysinger (UNITED STATES)

Message: 90701   

 

nothing was fixed in 2009R1.  only trunk was updated to a newer version.

QuoteReplyEditDelete

 

 

2010-06-29 05:36:09     Re: [2009R1.1-RC4] "stl/_config.h: No such file or directory"

Gilles Ganault (FRANCE)

Message: 90728   

 

Does someone know where this error comes from, and whether there's a work-around since this issue is still there in in the latest release of uCl?

 

Thank you.

QuoteReplyEditDelete

 

 

2010-06-29 15:24:41     Re: [2009R1.1-RC4] "stl/_config.h: No such file or directory"

Mike Frysinger (UNITED STATES)

Message: 90738   

 

the error is coming from the stlport dir as the old build logic in there is ****.  no idea how to make the old vesion work though.

QuoteReplyEditDelete

 

 

2010-07-04 07:05:40     Re: [2009R1.1-RC4] "stl/_config.h: No such file or directory"

Gilles Ganault (FRANCE)

Message: 90875   

 

Thanks Mike.

Attachments

    Outcomes