2010-04-22 12:16:19     mmc on spi bf533

Document created by Aaronwu Employee on Aug 21, 2013
Version 1Show Document
  • View in full screen mode

2010-04-22 12:16:19     mmc on spi bf533

Bob Flat (TURKEY)

Message: 88775   

 

Hi I am running  a Rubico Spi_mmc card reader on a bf533-stamp.

 

 

I am running the svn distribution, and went through all of the installing steps (except add a second extended file system) and compiled an image.

 

When I boot the image, GPIO is running,because i receive a signal whenever I take or insert the card, but I am not able to access it through /dev/ . Is there any other requiremen that I have to do? Do I have to put something on the daughter card o make it work?

 

Thank you

QuoteReplyEditDelete

 

 

2010-04-22 13:26:54     Re: mmc on spi bf533

Mike Frysinger (UNITED STATES)

Message: 88778   

 

if there is no card in the slot, then you wont get any device nodes

QuoteReplyEditDelete

 

 

2010-04-22 13:30:33     Re: mmc on spi bf533

Bob Flat (TURKEY)

Message: 88780   

 

I have a 256MB SD card in the slot, formatted in FAT32. Does the daughter card need any jumper or something like that?

QuoteReplyEditDelete

 

 

2010-04-22 13:42:35     Re: mmc on spi bf533

Mike Frysinger (UNITED STATES)

Message: 88781   

 

have you read the documentation ?  you need at least one jumper to select the SPI CS or nothing is going to work.

 

  docs.blackfin.uclinux.org/doku.php?id=linux-kernel:drivers:spi_mmc

Attachments

    Outcomes