2010-03-18 01:18:15     trouble getting started with BF537-STAMP

Document created by Aaronwu Employee on Aug 21, 2013
Version 1Show Document
  • View in full screen mode

2010-03-18 01:18:15     trouble getting started with BF537-STAMP

Hugh Shane (UNITED STATES)

Message: 87362   

 

Hi,

 

I'm having trouble building a plain old bootable kernel image for the BF537-STAMP.

 

U-boot: 1.1.6-svn

toolchain: 09r1.1-2

uClinux-dist: 2009R1.1-RC4

 

After unpacking the distribution, I follow the instructions in the README file, namely "make config" and "make". In the "make config" step, except for specifying AnalogDevices and BF537-STAMP, I accept all the default configuration values. When the build completes, I cannot find a uImage file anywhere in the tree. In an earlier post someone mentioned that I should find a bunch of files, including uImage, in uClinux-dist/images. I find nothing in this directory.

 

The README file mentions that the generated files can be found in ./linux-2.6.x/arch/blackfin/boot. In this directory I find the following:

 

lrwxrwxrwx 1 hugh hugh      10 2010-03-17 22:52 vmImage -> vmImage.gz

-rw-r--r-- 1 hugh hugh  882585 2010-03-17 22:52 vmImage.gz

-rwxr-xr-x 1 hugh hugh 1664660 2010-03-17 22:52 vmlinux.bin

-rw-r--r-- 1 hugh hugh  882521 2010-03-17 22:52 vmlinux.gz

-rw-r--r-- 1 hugh hugh    1296 2009-04-25 00:07 Makefile

-rw-r--r-- 1 hugh hugh    1485 2007-10-19 15:44 install.sh

 

Obviously, uImage is not found here. Where am I going wrong?

 

 

Thanks,

 

Hugh

 

QuoteReplyEditDelete

 

 

2010-03-18 01:22:17     Re: trouble getting started with BF537-STAMP

Mike Frysinger (UNITED STATES)

Message: 87363   

 

first, upgrade your u-boot to the 2009R1 release

 

the files under blackfin/boot/ are for people familiar with the kernel build system.  in other words, you shouldnt be looking in there.  please review the documentation:

  docs.blackfin.uclinux.org/doku.php?id=uclinux-dist:images

QuoteReplyEditDelete

 

 

2010-03-18 11:39:13     Re: trouble getting started with BF537-STAMP

Hugh Shane (UNITED STATES)

Message: 87408   

 

Mike: I read and (sort of) understand the documentation to which you pointed me. But my question still remains: what steps must I take to produce  the “default” uImage.rootfs file? The default make configuration does not seem to support this.

QuoteReplyEditDelete

 

 

2010-03-18 11:45:34     Re: trouble getting started with BF537-STAMP

Mike Frysinger (UNITED STATES)

Message: 87410   

 

you've shown no info to suggest that the steps you've executed did not produce the default uImage files

 

why exactly do you think things did not work ?

QuoteReplyEditDelete

 

 

2010-03-18 12:02:38     Re: trouble getting started with BF537-STAMP

Hugh Shane (UNITED STATES)

Message: 87415   

 

find . -name "*uImage*" -print

 

run from the uClinux-dist directory returns zero results.

QuoteReplyEditDelete

 

 

2010-03-18 13:10:33     Re: trouble getting started with BF537-STAMP

Mike Frysinger (UNITED STATES)

Message: 87420   

 

then, going by the documentation, what exactly is in the images/ directory ?

QuoteReplyEditDelete

 

 

2010-03-18 13:35:02     Re: trouble getting started with BF537-STAMP

Hugh Shane (UNITED STATES)

Message: 87424   

 

The images directory is empty.

 

hugh@hugh-laptop ~/uClinux-dist/images $ ls -al

total 8

drwxr-xr-x  2 hugh hugh 4096 2010-03-17 22:37 .

drwxr-xr-x 17 hugh hugh 4096 2010-03-18 09:51 ..

QuoteReplyEditDelete

 

 

2010-03-18 13:48:36     Re: trouble getting started with BF537-STAMP

Mike Frysinger (UNITED STATES)

Message: 87425   

 

run `make >& log` and post the log file as an attachment

 

QuoteReplyEditDelete

 

 

2010-03-18 14:28:39     Re: trouble getting started with BF537-STAMP

Hugh Shane (UNITED STATES)

Message: 87427   

 

Log file is attached

 

log.gz

QuoteReplyEditDelete

 

 

2010-03-18 14:39:11     Re: trouble getting started with BF537-STAMP

Mike Frysinger (UNITED STATES)

Message: 87428   

 

if `make` didnt complete successfully, i'm not sure why you'd expect the final result (images/) to be filled correctly.  fix the error and everything will "just work".

 

mkfs.jffs2.c:73:18: error: zlib.h: No such file or directory

 

in this case, you didnt configure your host system like the documentation explains.  you never installed the zlib development package.  please read:

https://docs.blackfin.uclinux.org/doku.php?id=installing_linux

QuoteReplyEditDelete

 

 

2010-03-18 18:57:13     Re: trouble getting started with BF537-STAMP

Hugh Shane (UNITED STATES)

Message: 87431   

 

It does work much better now that I installed all of the required development tools! My bad. Contents of the images directory are now as expected. Thanks for your help.

 

hugh@hugh-laptop ~uClinux-dist/images $ ls -al

total 25032

drwxr-xr-x  2 hugh hugh    4096 2010-03-18 14:46 .

drwxr-xr-x 17 hugh hugh    4096 2010-03-18 14:45 ..

-rwxr-xr-x  1 hugh hugh 9704871 2010-03-18 14:46 linux.initramfs

-rw-r--r--  1 hugh hugh 7509504 2010-03-18 14:46 rootfs.initramfs

-rw-r--r--  1 hugh hugh   30619 2010-03-18 14:46 rootfs.initramfs.contents

-rw-r--r--  1 hugh hugh  503726 2010-03-18 14:46 System.map.initramfs

lrwxrwxrwx  1 hugh hugh      16 2010-03-18 14:46 uImage -> uImage.initramfs

-rw-r--r--  1 hugh hugh 4727166 2010-03-18 14:46 uImage.initramfs

-rw-r--r--  1 hugh hugh  882582 2010-03-18 14:46 vmImage

-rwxr-xr-x  1 hugh hugh 2196903 2010-03-18 14:46 vmlinux

Attachments

Outcomes