2010-03-12 17:25:17     nand flash + bf548 -- anyone get this to work?

Document created by Aaronwu Employee on Aug 21, 2013
Version 1Show Document
  • View in full screen mode

2010-03-12 17:25:17     nand flash + bf548 -- anyone get this to work?

Rob D (UNITED STATES)

Message: 87144   

 

Hi all,

 

  blackfin.uclinux.org/gf/tracker/4443

 

I am experiencing this issue and I just want to know if anyone has found a solution.  I'm using 'nandtest' to test our nand chip.  If I disable the network (ifconfig eth0 down) - nandtest runs forever without failure.  If the network is up, nandtest fails really quickly.

 

I'm running on 2009R1-RC6. (I'm attempting to upgrade to 2009R1.1 soon, but I just noticed it was out as it was never posted on the front page)

 

I've attempted the patch in the tracker by Michael Hennerich but it still failed.

 

Any help would be appreciated!

 

Thanks,

Rob

QuoteReplyEditDelete

 

 

2010-03-12 17:34:51     Re: nand flash + bf548 -- anyone get this to work?

Peter Naulls (UNITED STATES)

Message: 87145   

 

I have not tried nandtest, but I am using yaffs on both 2009-RC4 and trunk (I patched yaffs back into the trunk kernel, yaffs is in a bit of flux right now, moving to git).  I have not written to it extensively, but have not seen any problems.

 

*However*, seeing as this appears to be a scheduler problem, what I can say is that using the CFQ I/O scheduler, an unclean ext3 FS on the hard drive causes the system to hang in scheduling with fsck - I've yet to report a bug on this so it could be entirely unrelated.  Using the Deadline scheduler avoids this - this is the default in any case.

QuoteReplyEditDelete

 

 

2010-03-12 17:52:10     Re: nand flash + bf548 -- anyone get this to work?

Rob D (UNITED STATES)

Message: 87146   

 

Peter,

 

I have tried jffs2 and yaffs - but they both eventually hang the board when doing network I/O - this is what lead me down this rabbit hole.  I just tried to switch to using the deadline IO scheduler and it appeared to work - but it eventually failed as well :/

 

Can you run nandtest and see if it breaks your board?

 

nantest -p5 /dev/mtd4 (note: this is destructive, use -k to make it not destructive)

 

The test I have been doing is just simply telnet'ing into the board and doing something like 'watch ls -l' or something.  The board should die in less then 1 minute.

 

Thanks for the response!

 

-Rob

QuoteReplyEditDelete

 

 

2010-03-18 14:12:44     Re: nand flash + bf548 -- anyone get this to work?

Rob D (UNITED STATES)

Message: 87426   

 

I updated to 2009R1.1 and the issue is still present.  I would really love for an Analog guy to chime in here and give their insight into the problem.

 

Thanks,

Rob

QuoteReplyEditDelete

 

 

2010-03-18 23:35:23     Re: nand flash + bf548 -- anyone get this to work?

Sonic Zhang (CHINA)

Message: 87435   

 

We haven't find the final solution to this bug yet. Please track the progress of this bug.

QuoteReplyEditDelete

 

 

2010-03-19 15:58:59     Re: nand flash + bf548 -- anyone get this to work?

Robin Getz (UNITED STATES)

Message: 87490   

 

Sonic:

 

Have you replicated the bug?

 

-Robin

QuoteReplyEditDelete

 

 

2010-03-22 00:03:07     Re: nand flash + bf548 -- anyone get this to work?

Sonic Zhang (CHINA)

Message: 87531   

 

Cliff had replicated this bug in 2009R1, but I haven't redone the testing recently.

 

I can have try on svn trunk.

QuoteReplyEditDelete

 

 

2010-03-22 06:20:30     Re: nand flash + bf548 -- anyone get this to work?

Sonic Zhang (CHINA)

Message: 87561   

 

This still fails on SVN trunk.

QuoteReplyEditDelete

 

 

2010-03-22 10:34:50     Re: nand flash + bf548 -- anyone get this to work?

Robin Getz (UNITED STATES)

Message: 87567   

 

Sonic:

 

Is there a bug tracker for this item? Is seems like we should get it resolved soon.

 

-Robin

QuoteReplyEditDelete

 

 

2010-03-22 15:39:35     Re: nand flash + bf548 -- anyone get this to work?

Mike Frysinger (UNITED STATES)

Message: 87580   

 

Sonic and Rob have already posted a link to the open tracker item ...

QuoteReplyEditDelete

 

 

2010-03-22 16:59:09     Re: nand flash + bf548 -- anyone get this to work?

Robin Getz (UNITED STATES)

Message: 87588   

 

Mike:

 

Got it now - thanks.

 

-Robin

QuoteReplyEditDelete

 

 

2010-03-22 22:45:42     Re: nand flash + bf548 -- anyone get this to work?

Sonic Zhang (CHINA)

Message: 87596   

 

Yes. It was in the first message.

 

  blackfin.uclinux.org/gf/tracker/4443

QuoteReplyEditDelete

Attachments

    Outcomes