2010-03-05 04:18:37     problem in PATA driver for IDE CDROM drive

Document created by Aaronwu Employee on Aug 20, 2013
Version 1Show Document
  • View in full screen mode

2010-03-05 04:18:37     problem in PATA driver for IDE CDROM drive

Zhi Qiang Zhang (CHINA)

Message: 86852   

 

I am using "Linux release 2.6.33-ADI-2010R1-pre-svn8389", it can detect the CDROM drive, but there is some error, here is the message,

 

ata1.00: ATAPI: ATAPI   DVD D  DH16D2P, HP55, max UDMA/33

ata1.00: configured for PIO

 

ata1.00: qc timeout (cmd 0xa0)

ata1.00: TEST_UNIT_READY failed (err_mask=0x5)

ata1.00: configured for PIO

 

ata1.00: qc timeout (cmd 0xa0)

ata1.00: TEST_UNIT_READY failed (err_mask=0x4)

ata1.00: configured for PIO

ata1.00: qc timeout (cmd 0xa0)

ata1.00: TEST_UNIT_READY failed (err_mask=0x4)

ata1.00: disabled

ata1: soft resetting link

ata1: EH complete

 

it can detect the IDE CDROM in the first line, but always got TEST_UNIT_READY failed.

 

what is wrong?

 

 

 

Regards,

 

ZhangZQ

QuoteReplyEditDelete

 

 

2010-03-05 04:56:24     Re: problem in PATA driver for IDE CDROM drive

Mike Frysinger (UNITED STATES)

Message: 86855   

 

you need to fully describe your hardware as well as your exact software setup

QuoteReplyEditDelete

 

 

2010-03-05 11:06:25     Re: problem in PATA driver for IDE CDROM drive

Zhi Qiang Zhang (CHINA)

Message: 86876   

 

here is the hard information

 

tatic struct pata_platform_info bfin_pata_platform_data = {

    .ioport_shift = 1,

    .irq_flags = IRQF_TRIGGER_HIGH | IRQF_DISABLED,

};

 

static struct resource bfin_pata_resources[] = {

    {

        .start = 0x203fff60,

        .end = 0x203fff7f,

        .flags = IORESOURCE_MEM,

    },

    {

        .start = 0x203fff50,

        .end = 0x203fff5f,

        .flags = IORESOURCE_MEM,

    },

    {

        .start = PATA_INT,

        .end = PATA_INT,

        .flags = IORESOURCE_IRQ,

    },

};

 

static struct platform_device bfin_pata_device = {

    .name = "pata_platform",

    .id = -1,

    .num_resources = ARRAY_SIZE(bfin_pata_resources),

    .resource = bfin_pata_resources,

    .dev = {

        .platform_data = &bfin_pata_platform_data,

    }

};

 

 

actually, this can work in the uclinux more than one year ago, I forgot the version number. I remember I used the "ATA/ATAPI/MFM/RLL support" option before, but now "ATA/ATAPI/MFM/RLL support" and "Serial ATA and Parallel ATA drivers" both can't work.

 

the attachment is the setting, can you help me to check what is wrong? thanks.

 

 

 

Regards,

 

ZhangZQ

 

zzq.config

Attachments

Outcomes