2010-02-02 10:52:41     I2C over TWI in BF527 not working

Document created by Aaronwu Employee on Aug 20, 2013
Version 1Show Document
  • View in full screen mode

2010-02-02 10:52:41     I2C over TWI in BF527 not working

Vinay Kumar (INDIA)

Message: 85467   

 

I am trying to interface using I2C on BF527 ezkit. I am not able to read or write to the i2c device. The same application is working with BF537 stamp.The kernel options I have selected while building is same for both the boards. Do I have to do any extra configurations on BF527? Does this I2C/TWI work on BF527?

 

Thanks.

QuoteReplyEditDelete

 

 

2010-02-02 11:02:58     I2C over TWI in BF527 not working

Michael Hennerich (GERMANY)

Message: 85468    Did you populate the STAMP ENABLE Jumper (JP3 close to the keypad)?

-Michael

QuoteReplyEditDelete

 

 

2010-02-02 11:26:40     Re: I2C over TWI in BF527 not working

Vinay Kumar (INDIA)

Message: 85469   

 

Hi Michael,

 

Thanks a lot for your time,

 

I populated STAMP ENABLE jumper, but still its not working.

QuoteReplyEditDelete

 

 

2010-02-02 19:17:47     Re: I2C over TWI in BF527 not working

Mike Frysinger (UNITED STATES)

Message: 85490   

 

have you checked the pins (SCL/SDA) with a scope to make sure they're wiggling ?

 

have you tried any i2c debugging tools ?  u-boot has bus probe commands and linux has i2cdump.

QuoteReplyEditDelete

 

 

2010-02-02 23:15:25     Re: I2C over TWI in BF527 not working

Sonic Zhang (CHINA)

Message: 85500   

 

What I2C device do you connect to BF527?  Did you put the i2c_board_info data of your device into the bf527-ezkit board file?

Attachments

    Outcomes