2010-01-12 09:15:09     Can't implement a UART using the Blackfin on-chip SPORT I/O interface

Document created by Aaronwu Employee on Aug 20, 2013
Version 1Show Document
  • View in full screen mode

2010-01-12 09:15:09     Can't implement a UART using the Blackfin on-chip SPORT I/O interface

Leandro Foltran (BRAZIL)

Message: 84466   

 

Hi everyone,

 

I am using the kit EZLITE-BF533 and uClinux-dist-2009R1-RC6.

I'm trying to implement the UART using the Blackfin on-chip SPORT I / O interface, I'm enabling uart sport in the kernel as described here:

  docs.blackfin.uclinux.org/doku.php?id=linux-kernel:drivers:bfin_sport_uart

but the devices ttySS0 and ttySS1 not appear when I run uClinux on the board. I think I'm skipping some step, but I can not figure out.

 

Could someone help me?

 

Thank you,

 

Leandro

QuoteReplyEditDelete

 

 

2010-01-12 13:39:38     Re: Can't implement a UART using the Blackfin on-chip SPORT I/O interface

Mike Frysinger (UNITED STATES)

Message: 84480   

 

you probably didnt add any platform resources to your boards file

QuoteReplyEditDelete

 

 

2010-01-12 16:47:41     Re: Can't implement a UART using the Blackfin on-chip SPORT I/O interface

Leandro Foltran (BRAZIL)

Message: 84485   

 

You're right mike! It's all working now, I applied the patch as described in   blackfin.uclinux.org/gf/project/uclinux-dist/tracker/?action=TrackerItemEdit&tracker_item_id=4944 and the devices ttySS0 e ttySS1 appeared.

Thank you very much!

 

Leandro

Attachments

    Outcomes